RockPro64 - Crash on flash startup (using official guide)

For Rockpro64 SMB, purchased new, first attempt at flashing it.

I have downloaded the recommended build as per

And successfully flashed following this guide (Ark decompress, etcher flash on ubuntu, onto Sandisk Class 10 64gb microsd)

On startup i get this screen

And it flashes this screen and goes black

Nothing else is plugged in besides hdmi and power.

Try adding nomodeset as kernel param.

Add it to what

That would be as an additional value to bootargs in uboot.

What is uboot? I said i was using etcher

Uboot is the text scrolling by in your 1st "screen shot".

Well, if you could direct me to a time machine ill be sure to freeze it during the 2 seconds that is on my screen before it crashes

That's your headache not mine, but uboot's usually interruptable.

Ah the typical linux response, thanks for all the help

Uboot isn't Linux though, but hey, whatever floats your boat.

Your attitude is linux, figure it for yourself noob, compile your own kernel and learn2code. Its apparent here that openwrt is incompatible with this board, yet i have been misled into buying this thinking that it is.

I have tried to flash every version of 20 series in the event maybe some older one would work, but nothing does, always the same result, crashing.

Technically, you don't know if it crashes, it might just set the video mode incorrectly.

If you're not willing to put any effort into trying to make it work, why should we?

You havent suggested a possible solution, you gave me a suggestion that i have no way of applying and then told me that its not your problem.

I think you should do some troubleshooting to make sure everything works as expected.
Does your board boot up without a display attached? If no, try using something that is known to work such as FreeBSD's 13.1 release image (or whatever floats your boat) to rule out any hardware issues. If that doesn't work, are you sure that your PSU proviides enough power? A quality 2A PSU should be fine but I would recommend 3A-5A if you plan to plug in a bunch of USB devices and/or PCIe cards. FreeBSD defaults to DHCP by default and also resizes the partition at first boot so it can take a while (usually 1-10 minutes) if you're running headless before the network interface comes up. I'm not sure if it affects OpenWrt but on FreeBSD 13.X (at least) there's a bug where 4k makes it freeze during boot, headless and/or 1080p displays works fine.

I would recommend using either dd or rufus (Windows) to write images to your SD card.

1 Like

It may actually have booted, but no video. Connect your PC to the Ethernet port and see if you can log in at

Pre-boot control of such boards is usually with a serial port. You would need a 3.3 volt USB-TTL converter.

On Linux, an image can be uncompressed and written to a card using gzip pipelined to dd:
gzip -cd openwrt-xxxxxx-bin.gz | dd of=/dev/sdX bs=4M
or with later kernels that allow writing a device as a regular file:
gzip -cd openwrt-xxxxxx-bin.gz > /dev/sdX