Roaming wifi with an Atheros and a Mediatek router


I have two routers a TP-Link TL-WDR4300 v1 (Atheros) and a TP-Link Archer C50 v4 (Mediatek).
Using these two routers I want to create a roaming wifi network.

Initially my idea was to connect the two devices over the 5GHz wifi and use the 2.4GHz wifi for the clients (not all clients support 5GHz).

The WDR4300 was the base station and the Archer C50 the "extender". So I created a regular 2.4GHz AP on the base station, for the 5GHz wifi I created a hidden WDS AP. So far so good, I can connect to both networks without any problems.

Now, I want to connect the "extender" to the base station. I could easily create a WDS client to connect to the 5GHz wifi. Now I want to create a 2.4GHz wifi network for the devices.

This is where I am having problems, somehow I cannot find a reliable way to create the 2.4GHz wifi network.

I have tried:

  • using the relayd package to bridge between the 5GHz wifi and the 2.4GHz wifi, using the following two tutorials
  • creating a bridge between all interfaces on lan
  • connecting each wifi network over WDS to the base station (I changed the 2.4GHz network to WDS AP for that, and created a seperate interface for 5GHz and for 2.4GHz so no routing between the two wifis), this seems to work for the 5GHz network, but I cannot connect the 2.4GHz wifi to the base station

Has anyone of you an idea on how to approach this problem? What would the proper solution look like? As far as I have seen, using the relayd package would be the best method, but it seems like I configured that wrong, or that there are some problems with the wifi drivers.

Base Station:
Version: OpenWrt 19.07-SNAPSHOT r10280-2b074654b0 / LuCI openwrt-19.07 branch (git-19.207.38473-c0057ae)
Device: TP-Link TL-WDR4300 v1 (Atheros)

Version: OpenWrt 19.07-SNAPSHOT r10352-73d45c7378 / LuCI openwrt-19.07 branch (git-19.241.48335-4109283)
Device: TP-Link Archer C50 v4 (Mediatek)

BR Patrick

If the two connect over WDS, then there's no need for relayd or other hacks. There should only be DHCP on one device. Bridge across the wireless and LAN ports, as desired.

I have already tried that, but it seems like this is not working properly.

Log on my PC (I replaced the mac-adresses):

[37332.797135] wlp4s0: authenticate with EXTENDER
[37332.805942] wlp4s0: send auth to EXTENDER (try 1/3)
[37332.918120] wlp4s0: send auth to EXTENDER (try 2/3)
[37332.980852] wlp4s0: send auth to EXTENDER (try 3/3)
[37333.031965] wlp4s0: authentication with EXTENDER timed out
[37333.192443] wlp4s0: authenticate with BASE_STATION
[37333.199221] wlp4s0: send auth to BASE_STATION (try 1/3)
[37333.209105] wlp4s0: authenticated
[37333.210824] wlp4s0: associate with BASE_STATION (try 1/3)
[37333.215873] wlp4s0: RX AssocResp from BASE_STATION (capab=0x431 status=0 aid=8)
[37333.222659] wlp4s0: associated

So it connects to the base station, even though the signal strength is quite bad for the base station.
The weird thing with that is, that it does connect to the extender if I choose the 5GHz wifi on my PC, it is just not working for the 2.4GHz wifi.

Set stp on on both LAN networks then you can connect the two routers by a cable bridge between the LAN ports (and leave the 5 GHz radios active, if a network loop forms the stp will prevent it from causing a problem). Once that is working (you can connect a wifi client on either one), disconnect the cable to see if WDS links them.

Test with everything in the same room so that signal strength is not an issue.

1 Like