Roaming not working on EAP245, whats wrong in my setup?

Hey!
I have been using my 4x EAP245 devices for quite a long time now.
Also i am running them using OpenWrt since the beginning, but i still didnt manage to get 802.11r running properly.

Whats wrong in my setup? I have never seen any device performing a successful roaming process at all.
These are my configs, confidential information has been omitted.
Maybe someone has got some idea :slight_smile:
Is there anything where an external RADIUS server might be useful here? I also want to move on to Enterprise authentication, but first of all, id like to fix the 802.11r issue.

Thanks in advance!

EAP245-1

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'secret'
	option key 'secret'
	option ieee80211r '1'
	option nasid 'B04E262E2857'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option mobility_domain '67c5'
	option pmk_r1_push '1'
	option ieee80211w '1'
	option encryption 'sae'

EAP245-2

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'secret'
	option key 'secret'
	option ieee80211r '1'
	option nasid '50C7BF8B46C9'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option r1_key_holder '50C7BF8B46C9'
	option pmk_r1_push '1'
	option mobility_domain '67c5'
	option ieee80211w '1'
	option encryption 'sae'

EAP245-3

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'secret'
	option key 'secret'
	option ieee80211r '1'
	option ft_over_ds '1'
	option ft_psk_generate_local '1'
	option nasid '50C7BF24A409'
	option mobility_domain '67c5'
	option ieee80211w '1'
	option pmk_r1_push '1'
	option encryption 'sae'

1 Like

I've never used 802.11r, so I can't comment specifically on this part of your setup. That said, here are some tips:

  • 802.11r is not supported by all devices and may be buggy on some that do apparently support it.
  • It is not necessary to have r enabled for roaming to work -- this is a standard that is otherwise known as fast roaming, but roaming should work without it (maybe even better than with it on).
  • You must make sure that you are using non-overlapping channels to the greatest extent possible for both bands. This should be no issue since you are using only 3 APs, so the 2G radio channels can all be unique, and of course 5G has many more channels available.
  • Try lowering the power of your APs. Ideally, the power will be sufficient to cover the necessary area while minimizing the overlap with the neighboring APs. If the power is too high, clients may not choose to roam to the nearest AP since they believe they have sufficient signal quality from the more distant one that they are already using. (roaming is a client side process; the APs do not directly impact roaming decisions, but they can be tuned to encourage the clients to roam).
1 Like

Oh, thanks for the advice regarding the channels. Is that mandatory? Currently all APs are using the same channels.
Thanks a lot for your reply!

Yes. Non overlapping channels is mandatory

I had problems with roaming for many months now, and apparently it is a supposed bug that affects 802.11r if 802.11w is enabled. I solved my problem by disabling 802.11w completely and using WPA2 (not WPA3, not mixed mode).

https://bugs.openwrt.org/index.php?do=details&task_id=4201

1 Like

Hey thanks a lot mate!! WPA2 solved the issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.