RNDIS USB Dongle and bridge

Hi,
I'm using
https://downloads.openwrt.org/releases/18.06.2/targets/x86/64/openwrt-18.06.2-x86-64-combined-ext4.img.gz
to make a 4G routeur using Android phone.

With my Huawei phone it works.
With my wife's Android S7 it doesn't. I have connection in the console and can do "opkg update" with no problem but bridge is off.

Network config

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd52:1f4d:398a::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'usb0'

config interface 'wan2'
        option ifname 'eth1'
        option proto 'dhcp'
        option macaddr '10:01:02:03:04:05'

You can see I don't get a mac address on the Samsung so I put one

Huawei info and route : it works

T:  Bus=03 Lev=01 Prnt=01 Port=03 Cnt=02 Dev#= 17 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1039 Rev=99.99
S:  Manufacturer=HUAWEI
S:  Product=PLK-L01
S:  SerialNumber=H8WDU15901004971
C:* #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=e0(wlcon) Sub=01 Prot=03
I:* If#= 0 Alt= 0 #EPs= 1 Cls=e0(wlcon) Sub=01 Prot=03 Driver=rndis_host
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_host
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.42.129  0.0.0.0         UG    0      0        0 usb0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.42.0    *               255.255.255.0   U     0      0        0 usb0

Samsung info : doesn't work except in the console (ping or opkg update for ex)

T:  Bus=03 Lev=01 Prnt=01 Port=03 Cnt=02 Dev#= 15 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04e8 ProdID=6863 Rev= 4.00
S:  Manufacturer=SAMSUNG
S:  Product=SAMSUNG_Android
S:  SerialNumber=8de22ebb
C:* #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=e0(wlcon) Sub=01 Prot=03
I:* If#= 0 Alt= 0 #EPs= 1 Cls=e0(wlcon) Sub=01 Prot=03 Driver=rndis_host
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_host
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.42.129  0.0.0.0         UG    0      0        0 eth1
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.42.0    *               255.255.255.0   U     0      0        0 eth1

Strange thing I get same ip address from the two phone.
Why Android is detected as eth1 and not usb1 ?
I rebooted openWRT quite a lot to be sure, no internet connection on br-lan

We do I have to look to?

Remi

I don't know why RNDIS is sometimes usb and sometimes eth. Do you have both wan and wan2 in the wan firewall zone? You can use a single WAN with two interfaces usb0 and eth1. Whichever one is up should work. If they were ever both up, there would be confusion.

When the WAN is DHCP, don't configure a gateway in the LAN settings.