Reverting to stock on Linksys WRT32X failed

Hey community,

I tried to revert to stock firmware on my Linksys WRT32x from 23.05 as described in the docs, but it did not work:

  • cd /tmp
  • wget https://downloads.linksys.com/downloads/firmware/FW_WRT32X_1.0.180404.58.img
  • sysupgrade -F -n -v FW_WRT32X_1.0.180404.58.img

Router has no ping, reboot does nothing, failsafe / rescue just reverted to OpenWRT 23.05.

Any ideas?

When I reverted a different Linksys router to OEM firmware and it was unresponsive I held the reset button down for about 10-15 seconds and it rebooted fine into the OEM firmware. It's worth a shot.

1 Like

I get lost with that "cd /tmp" after you have already downloaded the image to somewhere...

First cd to /tmp, then wget, then sysupgrade (once you have verified that the downloaded image has the right size (and checksum?))

(And why the && ? Just do separate commands at a serene pace...)

Regarding the actual issue, it is well possible that the stored OEM settings are from an earlier firmware version and somewhat incompatible. Reset might help, like suggested.

But it sounds strange that "failsafe" brings back OpenWrt. That sounds like you are not running OEM at all. (Assuming that you really meant failsafe mode via button during boot, and not just the dual-partition fallback)

2 Likes

My bad... I thought it was clear that I'm not a beginner :slight_smile: Sorry.

Well, I followed the described procedure and it did not work, so I thought it might be a mistake in the docs...

I'll try what @jc1685 suggested, but I think I might have tried this unsuccessfully.

Dual fallback may be an option that I did not recognize... I'll report back after reset.

Thanks

The original kernel partition size of w32x was too small and was increased somewhere around OpenWRT v22. Maybe this results in an issue when trying to go back to the age old vendor image, which likely is unaware of the changed layout.

you could try to revert the layout, if that helps:

  • to revert the layout, you could try to flash any older factory (not sysupgrade) image of OpenWRT, e.g. v 19. Flashing an old factory (instead of sysupgrade) OpenWRT would in addition also bring back the original w32x partition layout (don‘t do this on other device types carelessly, risk of brick).
  • then boot the older OpenWRT and flash the older OpenWRT factory image again. w32x alternates partition on each flash, and you may want to revert both partition layouts.
  • then flash the targeted vendor image
  • then optionally, boot the vendor firmware and flash vendor firmware again, if you want both partitions to go back to factory

(overall reasonable, if you want to sell it, but I would not really recommend the aged vendor image from 2018(?) for personal use)

I am not sure, if the doc is up to date here: I remember that I did revert mine to vendor image 2-3x over time. But for sure, I never needed the command line, I just flashed the vendor image via LuCi.

1 Like

Ok thank you. Yet another possibility. I'll try on Monday evening when I'm back home.
If it works, I'll update the docs

Yeah, its for selling the device in Original state.

Problem solved.

Flash 19.07 factory
reboot
Flash 19.07 factory again
reboot
flash FW_WRT32X

All via sysupgrade -F -n -v

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.