Reverting Linksys E4200 v1 to stock

Can someone please point me to a faq or tutorial or an english language YouTube showing how to revert an OpenWrt router back to the factory firmware?

I seem to remember that you can't just go into Luci and flash your original firmware from there. I'm also remembering something about uploading to /tmp and doing a sysupgrade but I don't remember the exact procedure.

Help or pointers appreciated. The old router I tried OpenWrt on is a Linksys E4200 v1

There is very little or no support for old Broadcom devices on OpenWrt such as e4200. For that reason, there is often no information on how to restore the Broadcom device to stock Linksys firmware, if it is not already described in detail in the wiki

https://openwrt.org/toh/linksys/e4200_v1
shows as 'under construction'.

I suggest you read this old thread.
https://forum.openwrt.org/t/bricked-linksys-e4200-v1/86804

Googling returns:

https://wiki.dd-wrt.com/wiki/index.php/Serial_Recovery

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=259297&postdays=0&postorder=asc&start=0&sid=9e5423be48d05b836e2bb1c299ab3dd8

2 Likes

Seems like the topic must have come up before, but searching the forum and the Internet, there's no clear tutorial to restore the stock firmware after you've flashed OpenWrt. That might be something for future development. Could not get any of the suggestions in the links to succeed.

I'd been warned before about OpenWrt and Broadcom when dealing with the built-in wifi of the Raspberry Pi 4. My idea was to free up my Pi with this router that has a 2.4 Ghz and 5 Ghz wifi and a decent amount of NVRAM and storage.

OpenWrt worked on it, but both the radios were limited to "generic 802.11 b/g."

radio1 has the Broadcom BCM4718 chip and radio2 has the Broadcom BCM4331.

Probably too old and slow for modern OpenWrt and as you say, not well supported. Just hoping to get the stock factory firmware back so I can donate a working router to Goodwill at this point.

I don't have any specific information about the E4200, but you might try tftp (send the stock firmware that you can hopefully get from the Linksys website).

I wrote about the EA6300 and tftp here:

1 Like

The stock firmware is no longer available from Linksys, but it was available on another website that aggregates old drivers. The tftp method requires using a small image. There's a small dd-wrt image I'm supposed to use first and then load the stock firmware from that. tftp seemed to work just as you described and all seemed to work, but there's some difference in firmware file formats and nothing changed after rebooting, it just didn't actually flash.

I forgot about the advanced boot package in OpenWrt. I should have done that first and I'm kicking myself. The other tips for theEa6300/6400 are good ones too and would have worked. Thanks so much for taking the time to help me. I'll be messing with it for a while. With OpenWrt it worked fine as a wired device. Should have stopped there.

What I'm trying to figure out now is how to get it to start from the rom partition that can't be erased and from there flash the stock firmware. Searching the internet to find that arcane detail is tough for an old device. I can remember there is a reset button power off and on or some such sequence to get it to do that, but I haven't found it online.

Note to self: Technical Data - Linksys E4200 v1.0

Note to self: Compatibility - Linksys E4200(v1) - No wiki page, lists 14.07 OK?