Revert to stock firmware on Asus MAP-AC2200

Due to the problems in https://forum.openwrt.org/t/openwrt-22-03-0-rc1-first-release-candidate/126045/112?u=tboege I would like to be able to revert to stock firmware.

How do I do that? - I cannot find the instructions on https://openwrt.org/toh/asus/lyra_map-ac2200

Have you tried to use the Asus Restoration tool?

https://www.asus.com/uk/support/FAQ/1000814/

Thank you for your suggestion.

I have tried now, but the restoration tool failes to find and connect to the ap.

I took the change and use Luci to upgrade. I had to check "force" before it accepted to flash and rebooted. But something must have failed, because when it was ready, it was still running Openwrt.

I have also tried to flash openwrt-22.03.0-rc1-ipq40xx-generic-asus_map-ac2200-initramfs-fit-uImage.itb -but the same happened: It rebooted and went back to openwrt.

Serial console access is probably required, while the device has tftp push-button recovery, it's not working reliably (with changed ubi partitions). For recovering OpenWrt, one would tftpboot an initramfs image from the bootloader using the serial console - and then sysupgrade a normal OpenWrt image. I've never tried if the OEM firmware can be RAM booted.

I have a functional openwrt on the device, but want to get back to stock firmware.
I was hoping to avoid to open the box and solder. Since the device is running openwrt, I would like to use the full access to write the stock firmware to the device, maybe with som mtd magic?

I have retried the firmware restoration tool - and this time it succeded to upload the firmware - according to the tool itself. But it still boots up in Openwrt.

If I capture the sequence with wireshark, a lot of tftp packed are transfered, but the last entries was:

105577	15.603411	192.168.1.10	192.168.1.49	TFTP	Data Packet, Block: 54087 (last)	
105578	15.603640	192.168.1.49	192.168.1.10	TFTP	Acknowledgement, Block: 54087	
105745	27.415810	192.168.1.49	192.168.1.10	TFTP	Option Acknowledgement[Malformed Packet]

The last entry repeated 6 times

I didn't find a way using tftp, but I also ran out of patience and just heated up the soldering iron (and recovered to OpenWrt directly, instead of bothering with the stock firmware).

21.02.x (kernel v5.4) should not be affected by the led controller changes.

I have still one ASUS MAP-AC2200, which is running stock firmware.
I have modified the script from wiki:
I now have the files:

1:/volume1/NetBackup/ASUS-MAP-AC2200-nanddump$ ls
backup.sh  mtd0_Bootloader.backup  mtd1_UBI_DEV.backup  mtd2_nvram.backup  mtd3_Factory.backup  mtd4_Factory2.backup  mtd5_linux.backup  mtd6_rootfs.backup  mtd7_linux2.backup  mtd8_rootfs2.backup  mtdinfo.backup

Is it enough to revert to stock firmware (if I ever want that)?

#!/bin/sh

BACKUP_HOST="192.168.91.11"
BACKUP_USER="tbnadm"
BACKUP_DST_PATH=/volume1/NetBackup/ASUS-MAP-AC2200-nanddump
echo "Backup host ${BACKUP_HOST}"
MTDINFO=/tmp/backup.mtdinfo
echo > $MTDINFO
cat /proc/mtd | tail -n+2 | while read; do
  MTD_DEV=$(echo ${REPLY} | cut -f1 -d:)
  MTD_NAME=$(echo ${REPLY} | cut -f2 -d\")
  echo "Backing up ${MTD_DEV} (${MTD_NAME})"
  mtdinfo /dev/${MTD_DEV} >>$MTDINFO
  nanddump /dev/${MTD_DEV} | ssh -p8022 -y ${BACKUP_USER}@${BACKUP_HOST} "( cat > ${BACKUP_DST_PATH}/${MTD_DEV}_${MTD_NAME}.backup2 )"
done
cat  $MTDINFO | ssh -p8022 -y ${BACKUP_USER}@${BACKUP_HOST} "( cat > ${BACKUP_DST_PATH}/mtdinfo.backup )"
rm $MTDINFO

I would guess that something similar to https://openwrt.org/toh/asus/rt-ac58u#returning_to_stock might work, tricking the OEM firmware restoration tool into working (which fails in the presence of non-OEM ubi volumes).

Thank you. It seemes likely, that I could use a similar approach. I have already got serial access by soldering, which I think i nescessary because the bootloader recovery doesnt seem stable.
I will bookmark the suggestion - and try it a day, where I feel brave...
BTW the led issue is gone in master, shortly after I raised an issue on github.

1 Like

did you try this and did it work?

No, I never tried it. Please update wiki if you do (with success)