Revert to official OEM GS308T

Hi everyone,

I was wondering if there was any other solution to revert to the official OEM of the GS308T.

As from what i saw on the discussions there are a few methods but non of them is working. When i reboot my switch all the configuration is lost. Do i was wondering if any of you could have any about how to revert to the official OEM. I tired TFTP, and webgui of OpenWRT but seems also that the official OEM has extension .BIX wich I never heard about it.

Thank you in advance guys !

What does Netgear's documentation say about its recovery procedure? Most of the Realtek switches allow you to TFTP boot through serial access.

From the device hardware data -

Comment recovery:

  • Stock firmware still available in alternate partition which can be set from U-Boot*

Uhu, but when i try to boot on it with the applications (tftp64, tftp2, nmrpflash) but none of them worked.

I also tried to check the open ports on the switch when it reboots and the only open port is the 22. The 69 isn't open.

And from what I saw on Netgear's documentation we are only allowed to upgrade the firmware with the webgui of the original firmware. :confused:

I didn't find how to boot with U-Boot or not on this swicth :confused:

You would use a serial connection.;a=commit;h=c829bc1f2c3c47e230905864f2f5f8c759f88ce6

Hmm is there another option without opening the switch ? I would like to send it back to amazon and buy a fully managed switch. I think if I open it I cannot send it back right ?

And it's not a firewall issue?

I dont think so, i've allowed all the connections :confused: I maybe should desactivate it and try again but not sure it will change something but i'll try to be sure

Didn't change anything :frowning: ..

I deactivated my firewall but it didn't solve the issue. Anyone any other solution ?

I own a GS308T too.
This is how i change active image from console to switch from openwrt to oem firmware:

dd if=/dev/mtd2 of=/tmp/mtd2
sed -i s/bootpartition=0/bootpartition=1/ /tmp/mtd2
mtd write /tmp/mtd2 /dev/mtd2
hexdump -C /dev/mtd2

That's what uboot-envtools is for :slight_smile:. On my GS108T v3:

# fw_printsys
# fw_setsys bootpartition 1

This assumes that you kept the OEM firmware intact in the second system partition. You should definitely verify this before rebooting. Do NOT set bootpartition to 1 unless you know the image in the second system partition is bootable! If it is not, then you serial console will be required to fix the mess...

A simple (but not 100% failsafe) method is to take a simple look at the partition header:

EDIT: I see that your runtime2 partition is mtd6. This is the one you'll have to look at.

(the reason is related to that rootfs_data warning - you have an incomplete OpenWrt installation)

root@OpenWrt:/# hexdump -n 100 -C /dev/mtd9
00000000  4e 47 45 20 11 45 09 fd  5f 4f d1 d8 00 8e 05 13  |NGE .E.._O......|
00000010  80 00 00 00 80 2d 48 b0  0d b9 20 5e 05 05 02 03  |.....-H... ^....|
00000020  37 2e 30 2e 34 2e 38 00  00 00 00 00 00 00 00 00  ||
00000030  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000040  5d 00 00 00 04 ff ff ff  ff ff ff ff ff 00 00 6f  |]..............o|
00000050  fd ff ff a3 b7 7f 63 c5  55 81 bd 5b 5e 9d 54 f7  |......c.U..[^.T.|
00000060  9d ec 67 91                                       |..g.|

You'll notice the third line (bytes 32 etc, or 0x20 hex) shows a Netgear version number in plain ASCII:

This example is from my GS108Tv3. But the GS308T should be similar. If it shows something like that, then you can set bootpartition to 1 and reboot.

I'm not sure about the status for the GS308T images, but ideally you should be able to use the fw_printsys and fw_setsys commands to manipulate this variable.

root@OpenWrt:/# fw_printsys 
root@OpenWrt:/# fw_setsys bootpartition 1
root@OpenWrt:/# fw_printsys 

If you don't have an OEM firmware image, then you can easily install one. Just download it from Netgear, unzip it (probbly have to do this outside the switch since unzip isn't installed by default), transfer the image to the switch and flash it. I.e. something like (assuming the switch management address is

scp GS308T_310TP_V1.0.4.4.bix root@
ssh root@
cd /tmp
mtd -e runtime2 write GS308T_310TP_V1.0.4.4.bix runtime2

Followed by a visual inspection of the partition header and setting bootpartition=1 as descibed above.

WARNING: Completely untested. Please sanity check every command yourself. Do not trust me...