Revert OpenWrt to factory firmware on a GL.iNet GL-B1300

Dear all,

I would like to revert to the original factory firmware that is also based on OpenWRT on a GL-B1300 device. Could you please tell me how I can do that?

If I uploaded the factory image in LuCI, I got the message:

"Image metadata not found Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

I did not do anything at this point.

Thank you in advance! :slight_smile:

TFTP should work

Thank you. :slight_smile:

I could not make it work.

I downloaded tftpd64 (Windows), set the ethernet connection's IP to (I have tried as well), placed a file called lede-gl-b1300.bin in the TFTP server's folder. I set the IP in the tftpd64 program. The router was powered off, and connected to my PC through a LAN port (not WAN). I tried starting the router while holding the reset button, I tried powering it on and then pressing reset, in all sorts of combinations. Still, no success.

I also tried the DD-WRT tftp utility. I set the server to, selected the file, and tried upgrading. Still, no success. After a few times, this utility wrote: "Erasing Flash... (It may take long time, please wait.)" So I could not do any further tries. I think I also tried and as the computer's IP address.

I also tried pressing the reset button, holding it and not pressing it at all.

Could you please tell me what I am missing?

1 Like

Hi, I know it's an old topic, but since I had the exact same issue (I think), I will post it in case somebody finds it helpful.

It took me a lot of time and different configurations and attempts, but in the end what worked was the debricking guide of GL from here:

I would describe the steps but they are more or less exactly as in the guide. The only problem I had is that the device wouldn't always be accessible at or anywhere else, but after rebooting it and my computer a few times, I managed to get it working and I uploaded the .img firmware file, which worked this time.

@Oak Does the debricking guide linked by Nik work for you?

Hi, I am sorry for not marking this topic and not noting that the problem I had became irrelevant.

@Nik, thank you for your help.
@tmomas, I do not know if this method would work for me or not, because I do not want to flash the original firmware anymore. Shall I still mark it as a solution? How can I mark topics like this in the future according to the forum rules?

Initially, I had a problem with configuring VLANs in LuCI. For this reason, I wanted to flash the original firmware and return the router. But after that I found a solution on this forum. If someone's interested, you can find the solution adapted to this router here.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.