Reverse engineering ISP settings

Hello All,

I recently bought a new modem (TP Link Archer C7) and successfully installed OpenWRT. No problems in flashing, it was very easy with the web interface.

The trouble is ISP connection. My ISP (NetCologne) is not listed here, and they are not providing WAN connection details either. I managed to a reach customer service rep that was very friendly and tried to be very helpful, but the he lacked the technical knowledge to help me out (and I can't really reach someone more technically qualified). From what I could gather by looking at my old FritzBox, it uses PPPoE and Annex B, and the connection probably needs a VLAN tagging for 7. However, WAN is currently not working based on the config I managed to create from those. (see attached /etc/config/network)

  • Is there a best practices guide for reverse engineering ISP settings? How did the list here get created in the first place: https://openwrt.org/docs/guide-user/network/wan/isp-configurations

  • Is there anything obviously wrong in my config?

  • Is there some way I can exract these settings from my old FritzBox? As far as I can tell, FritzBox'es don't support ssh by which I can pull config files.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '******::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr *********

config interface 'wan'
	option proto 'pppoe'
	option username ****
	option password ****
	option ipv6 '1'
	option device 'eth0.7'

config dsl 'dsl'
	option annex 'b'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option vid '7'
	option ports '0t 1t'

config switch_vlan
	option device 'switch0'
	option vlan '8'
	option ports '0 2 3 4 5'
	option vid '1'

Have you tried to place your ISPs router in bridge mode to logging in to your ISPs router web interface?

Seems like NetCologne uses ppoe.

Otherwise, you might get some ideas from:

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=146644

The Archer C7 is not a modem. Unlike most of the Fritzboxes, it can't be connected directly to a DSL line. The hardware ports only operate as Ethernet. You need a two-box system with the modem box converting Ethernet signals to DSL.

The configuration of the modem will affect how you configure the WAN port and network or your C7. In some cases the modem will add or remove a VLAN tag, or if operating as true bridge it will pass through whatever tag exists on the DSL line. Then you have to match that.

One mistake in what you posted is that the CPU port in the switch (port 0) should be tagged in both the lan and wan VLANs.

2 Likes