Returning from static to DHCP fails

I am trying to set up a router of a RPi4 plus an LTE modem.

For getting the network available for installing the necessary QMI stuff I need to connect the RPi temporarily to my router, but returning from DHCP to static address on the LAN port fails. This is what I did:

  1. Connect my laptop to LAN port
  2. Edit /etc/config/network from static to DHCP
  3. Connect to the RPi to the router
  4. Install the QMI etc packages
  5. Edit /etc/config/network proto back to its original setup
  6. Connect my laptop to LAN port like in step 1. => No network

I also installed Luci and tried to set LAN back to static there, but still I get no connection.

What I am doing wrong?

How did you change /etc/config/network ? What did you do after the change ? Reboot ?

1 Like

In phase 2. commented the rest of the lines except eth0 and proto that I changed from static to dhcp. That worked fine, and I could connect through the router.

In phase 5. I removed the #'s and changed dhcp back to static, exactly the original config, but no go.

After the changes I rebooted.

And you still cannot connect to the device ?
If not, what happens if you again connect the device to your router and reboot again ?

If you can connect again, how does the /etc/config/network look like now ?

If you still cannot connect, please see

1 Like

Got it. For some reason the changes back to static were not stored at least when done with Luci.

I tried again and waited to see the change confirmation, and got "Failed to confirm apply within 90s, waiting for rollback…"

I test a bit more.

If you click on the small drop down of the Luci save&apply button (to the right hand side of the button), you see an "apply unchecked". But use it with care.
But you cannot change the ip of the device with luci other than using apply unchecked, it will always rollback the changes...

1 Like
1 Like

Yep, this was the case with my attempt with Lucy. Apply Unchecked helped.


This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.