Restoring configuration indicate wrong firmware version

hello everyone,
little issue
Following factory reset, upgrade to 22.03.5 and uploading backup config, the system info indicate old firmware version of 22.03.2 instead of latest upgraded version which is 22.03.5.
causing issue for package install after config restoration
had to proceed the other way round, which is upgrade from 22.03.4 to 22.03.5 then package install everything needed and after that upload the config backup.
so far ive replaced the content of:
openwrt_release
openwrt_version
to display latest upgraded version release

any solution for this issue?

device affected here:
miwifi 3g
wdr4300

What was in the backup? If you backed up (and subsequently restored) all of /etc, this could appear to happen due to the banner and other files coming along from the old version. Your version cannot be downgraded just from a restore operation, though.

If this is the culprit, it is unlikely to cause any issues now (although expired certs could bite you at some point). But, you could potentially run into other issues when you make a major upgrade (like if/when 23.x comes out or anything beyond that.

What is the output of ubus call system board

1 Like

ubus call system board

ubus call system board
{
	"kernel": "5.10.176",
	"hostname": "Route",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "Xiaomi Mi Router 3G",
	"board_name": "xiaomi,mi-router-3g",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.5",
		"revision": "r20134-5f15225c1e",
		"target": "ramips/mt7621",
		"description": "OpenWrt 22.03.5 r20134-5f15225c1e"
	}
}
cat banner


  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.2, r19803-9a599fee93
 -----------------------------------------------------

indeed i backed all of /etc :frowning: lot of colders with various extra service scripts inside,
will try resetting the device and moving the items individually.

thank you

You're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.