Restore stock firmware (low memory, can't SCP binary image file)

I have very old NETGEAR WNR1000 v3
It was fully functional but obsolete, i wanted use it as AP Client but stock firmware does not have this function. I was pretty sure OpenWRT would carry this job flawlessly but sadly after flashing it so slow that accessing SSH took couple of minutes, main reason would be terrible small RAM on that device with is 16MB.

Yes there was a warning, but as I told, i just wanted AP Client and i hope that it will work.
Now i would like go back, to stock firmware, but i hit on problem.
I'm trying SCP stock firmware with command:
scp firmware.chk root@

but it fail about 37%.
I assume that is caused by lack of memory on RAM drive.

Could someone give me advice what could be deleted to free up RAM drive and allow to flashing firmware?

PS: I was trying TFTP on "boot" but for weird reason, it don't work. My next try would be connect via RS232 (if possible) but i hope we manage to find solution to do it via sftp.
Best regards

Just be aware, the 4/32 warning is a real problem for devices with 32 MB already - devices with only 16 MB RAM really aren't usable in any way, shape or form anymore. They will crash with out of memory errors without even doing anything special, even more so once the wlan drivers get loaded (and used). You can find quite spectacular devices (superseding the minimum system requirements easily) for the equivalent of a fast-food meal and a cold beverage on the used market, a 4/16 device really is better suited for the recycling bin.

Thank You for reply,
I tried, but it failed, with output:

 cat firmware.chk | ssh root@ mtd write - firmware
root@'s password: 
Image check failed.

This is stock firmware, i'm positive it's correct because i did flash it before trying OpenWRT via web interface, and it was working correctly.

Could You give me other advice?

Does it have CFE recovery mode?


have you seen this, it worked for me.