Restore not working in OpenWrt 22.03.0-rc5 r19523-bfd070e7fa

Good afternoon everyone.

To save myself some time, I decided to create a backup after completing the configuration of a new device. Then, I would be able to reset the device, restore the backup and get back to a known good state for the router, while I experimented with some features.

However, I am finding that the backup file cannot be restored using Luci, the command line or a tar extraction. The errors I am seeing are as follows:

  1. Luci (restore backup/upload archive): The uploaded backup archive is not readable
  2. Command line (sysupgrade --restore-backup backup-OpenWrt-2022-08-01.tar):

tar: invalid magic
tar: short read

  1. tar -C / -xzf backup-OpenWrt-2022-08-01.tar: the same as above.

I am able to extract the files without issue on my Mac, so the archive appears to be valid.

Any help resolving this would be very much appreciated. Thanks.

Mike

Note, before spending more time on your release candidate 5,
Release candidate 6 for your router may already be available for download.

In all fairness, the RC6 build only appeared today :). However, I have upgraded my system and tried to create and restore a backup with the same results.

Judging from the mentioned file name, the .tar is not GZIP compressed anymore which might trip up the tools. (LuCI just reuses the sysupgrade command internally).

Can you retry after gzipping the .tar file again?

1 Like

Being new to Openwrt, I was not aware it was previously gzipped. When I gzip the tar file and try to upload it, it is accepted. I have not tried the restore yet, because I can't at the moment. However, the issue needs to be changed to this:

The created backup archive is no longer gzipped :slight_smile:

It is for me, I suspect some Browser or OS X heuristic is interfering.

2 Likes

Thanks again. I believe that OSX is likely "unzipping" the file when it is downloaded, leaving nothing but the TAR file. I should have realized that earlier, but appreciate the pointer in the right direction.