Restore Netgear D7800 original firmware upload not working

due to the fact that the openwrt firmware for the Netgear D7800 doesn't support it's dsl interface ii opted to restore its origional firmware.
I saw some instrutions on netgear's site where i downloaded th firmware then i looked here.

heres what i did.

1. Downloaded the firmware
2. unzipped the file.
3. the router was already off so i didn't need to turn it off
4. plugged an ethernet gable into port 4  of the router  and the other end into my laptop
5. held the reset button an powered on the router. holding down the button until the power light blinked
started tftp on my laptop
6. typed the word binary and pressed enter
7.typed put <filename of the firmware>

the power light went off as it was supposed to
but the started blinking again.

i manually rebooted the outer and openwrt was stll there

here's what else i tried
1. renaming the image to factory.img and tried again. no luck
2. attempted to do the web ui to do the upgrade. i read on other sources that that may brick it, but that was my intention as i wanted a blank canvas. i assumed that if no firmware at all was found the router would allow my to install the origional. it gave the warning. i told it to force. it did so. rebooted. it ws bricked n openwrt was still there
3. went into tftp folowing the steps above and tested to see if it would allow me to upload the openwrt image.that succeeded. it installed the firmware even though it was already installed and rebooted.
so it allowed me to reinatall openwrt but not the orgional firmware.

my thoughts on this are that the router sees the openwrt image as newer and therefore failed to install an older image. so how do install the older image? the origional firmware?

thank you

Check if nmrpflash works with the 7800.

1 Like

i think that only might work if the router ws briced. it's not. it just own't restore the origional firmware

You think incorrectly.

1 Like

As long as the bootloader is ok, nmrpflash works anytime, whatever the router is bricked or not. So in your case it should work. Just try.

according the the documentation. it's meant to work on bricked routers. whetehr that's it's limitation or not is incdentaly as it didn't work on mine

it didn't work on mine.

evidence would suggest it doesn't

I'd already tried. it was worth a try sadly it dod not work. nmrflash sat there waiting for the touer to get in touch, the router light was blinking what as itshould have been but it never contacted nmrpflash which times out after 60 seconds. yes they were both on the same network and could see each other.

Try both to start the router before the command, and the command before the router. I had different behaviors depending on the device.

If nmrpflahs starts, wait long enough at the last step. I have a device that requires more than 4min.

Also use npcap 1.60. I couldnt make 1.72 and 1.74 work.

well i followed the instructions which said run it when the light starts blinking. it times out after 60 seconds so if i started it while waiting for the blinking it may well have timed out before the router wsa ready

i'm using a mac. it comes with pcap installed. i don't know what version it is.

try different timings. Sometimes it took me several tries before finding the right timing.
Have your though about allowing the firewall?

Well, nobody's perfect! (just kidding)

the tftp methind isn't failing to upload. it's just faiiling to install it. when i do the upload it comes back after a few minutes and tells me that's it's uploaded with a byte count. it just doesnt install it. the only reason why i think it won't is that it detects the existing firmware is newer. if the firmware was empty like a blank hard disk it would probably install.


The problem is sorted. I was trying to upload the wrong image.

1 Like

Well done. That tool never failed me. It can ben tricky (power on timing, npcap version), but it works.
Just for kidding #2, I own a Mac from 1986. That's a tough piece of hardware.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.