Restore default config for network

Hi, I have been using the 2.5GHz network only so far, so I kept the 5G decide disabled in my config. I have now enabled the 5G device but it always shows as "Device is not active".
I am sure it was working years ago before I disabled it, but over time my device has been upgraded multiple times (I am on latest now) and I always keep the existing config when upgrading, so I wanted to check whether there is a simple config issue.
Here is my config for the 2 wireless devices in /etc/network/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'GB'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option country 'GB'
        option channel 'auto'
        option cell_density '0'

The thing that I am not sure about is the path value in radio0 (which is not working), is that correct? I have never touched it but it is definitely too different from the value in radio1 (which is working).
My device is Ralink Rt3883, can I restore the wireless config only in any way before I try a full reset? If not, is there anywhere I can look to see the default config for my device to compare with mine first?

You can move the current config to /tmp and then reset to defaults

cd /etc/config
mv wireless /tmp
wifi config

Note the config file you moved to /tmp will be gone after a reboot so transfer to your PC for permanent backup

thanks, I tried that but then I see a different issue, because there is only radio0 discovered (the 2.4GHz) so the 5GHz device is missing completely:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
...

I guess the issue is either hardware (my device) or "discovery of hardware" in openwrt for my device...
Model: TRENDnet TEW-692GR
Architecture: Ralink RT3883 ver:1 eco:5

That does not look promising indeed.

I do not know how difficult it is to go back to stock to see if it is a hardware problem but if it is easy you can try that.

Furthermore I do not know which version you are using but you might want to upgrade to 23.05.3

https://openwrt.org/toh/trendnet/tew-692gr

If you have never enabled the 5g band, try to activate thus:

uci set wireless.radio0.disabled='0'
uci commit wireless

Also, option hwmode has been deprecated since '21.02.2' and should be changed to:
option band 2g # for 2.4Ghz
option band 5g # for 5Ghz