Resolvfile option not showing in luci 19.07

LUCI no longer shows an option to specify a resolvfile since 19.07. Some searches fail to indicate anybody else has noticed this so I suspect something off with my config. I can manually edit dhcp.conf with the option and it works fine and so it's a first world issue. I thought I would throw it out there in case there was a logical explanation.



I can't specify the file either on 19.07 on BTHH5A.

It is indeed a bug in LuCI. You can hotfix it on your router using the command below:
sed -i -e "s#depends('noresolv','')#depends('noresolv','0')#" /www/luci-static/resources/view/network/dhcp.js


Didn't work. No error but no place to specify the file.

Same result here.

Did you clear your browser cache?

Yes, and tried different browsers too.

Same thing here. I thought maybe because I had removed the resolvfile option that was an issue so I put it back in - no change. Anyway, it's no big deal. at least we know its a bug so we just wait until the next release, it is only a minor inconvenience :blush:

Forgot that the production files are minified, so the proper command is:
sed -i -e "s#depends('noresolv','')#depends('noresolv','0')#" /www/luci-static/resources/view/network/dhcp.js

The spaces must be removed.


This worked. Thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.