[Resolved] SQM doesn't work - Belkin RT3200

Hi, after reading the wiki I decided to install SQM for traffic shaping and to reduce the bufferbloat of my internet connection.

Background info: my router is Belkin RT3200 with the latest version of OpenWRT 22.03.3 r20028-43d71ad93e, the WAN port is connected to my WISP's CPE via PPPoE client.
The nominal and actual measured line speed is 30/3 Mb/s.

Here's my current SQM config

config queue 'eth1'
        option script 'piece_of_cake.qos'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option interface 'pppoe-wan'
        option linklayer 'none'
        option qdisc 'cake'
        option download '25500'
        option upload '2550'

I tried changing the download/upload shaping speed, the target interface, cake/fq_codel queuing method and the lynk layer adaptation settings on the luci-sqm interface, nothing seems to improve bufferbloat in dslreports and waveform website (C/C on the first, D or F on the latter).

Before SQM and after the bufferbloat results are ~30/3 Mb/s, ~20ms latency unloaded, 20-50 ms dl active, 400-600 ms ul active.

I followed the troubleshooting guide on the wiki, but i haven't seen anything that ringed a bell on my brain.
I also tried rebooting and restarting the sqm initscript, as I've seen this suggestion in older posts on this forum, but nothing made a relevant difference.

I thought that with SQM the speedtest results should have been lower, similar to the shaping speed that I set on the luci interface, instead they are still ~30/3 Mb/s. Is this supposed to be the case or are my settings faulty?

It was user error... After more searching in the forum i found out that software/hardware flow offloading (which was active) isn't compatible with SQM/QoS. Now the bufferbloat results are what I was expecting.

I think a note on the wiki page for SQM regarding the mutual exclusivity with sw/hw flow offloading might be helpful. I ignored the desription in luci, my bad.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.