Resizing root partition on X86_64 - OpenWrt 21.02.1

Hi there! I successfully installed OpenWrt 21.02.1 on my notebook, version X86_64 (I chose COMBINED-EFI EXT4) and I resized the root partition, as described here, so I rebooted but I got the system halted :frowning:

So I reflashed my ssd ex novo, now blkid said:

/dev/sda1: SEC_TYPE="msdos" LABEL_FATBOOT="kernel" LABEL="kernel" UUID="4FDC-F612" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition"
/dev/sda2: LABEL="rootfs" UUID="ff313567-e9f1-5a5d-9895-3ba130b4a864" BLOCK_SIZE="4096" TYPE="ext4"
/dev/sda128: PARTUUID="c58d873d-8ab8-7349-ea70-2ab0e496b780"

and what parted shows:

Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
128     17.4kB  262kB   245kB                                      bios_grub
 1      262kB   17.0MB  16.8MB  fat16        EFI System Partition  boot, esp
 2      17.3MB  126MB   109MB   ext2                               msftdata

May the problem is the /dev/sda128 - bios_grub partition, that also need to be modded? But how?

Thank you in advance, cheers

1 Like
1 Like

Thank you and compliments for being the maintainer of that wiki, it worked! I thought that passage was referring to automated method, so I never used it because it worked great before, when using 19.07.8. But this newer version introduced that new partition /dev/sda128 - bios_grub, is perhaps to better support EFI?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.