Reset button doesn't work at custom OpenWRT build

I am compiling a custom OpenWRT firmware for router WL-WN527G4 REV.A (MT7621).

This router has a reset button. This is a physical button on router's back. But this button doesn't work in my compiled firmware. Nothing happening when I press this button.

I have connected router to my PC using UART console and "minicom" app and there is no any output in "minicom" when I am pressing reset button. I have checked output with "logread" util on router and there are nothing here also.

There is a file "/etc/rc.button/reset" with a reset script but I think it not being executed. Also there is no "gpio" directory in "/sys/class".

I think I have missed some kernel modules while compiling OpenWRT. But I don't know what modules I should enable to make this button work.

My ".config" file contains next lines related to gpio:

CONFIG_DEFAULT_gpio=y
CONFIG_PACKAGE_kmod-input-gpio-keys=y
CONFIG_PACKAGE_gpio=y

How can I get know what modules I should enable to make this button work?

you might try kmod-gpio-button-hotplug. That is the usual one in router target definitions. But it should selected by default by the ramips target, unless you have deselected it.

It is also the question of defining the key correctly in DTS.
E.g. https://github.com/openwrt/openwrt/blob/master/target/linux/ramips/dts/WN3000RPV3.dts#L72

try this link
https://wiki.openwrt.org/doc/howto/hardware.button
you can see the result of your button in the log

This module was not selected by default. I have compiled with this ones, but again with no success.

I think the problem can be here.
I am compiling openwrt using sdk from file named mtk-openwrt-sdk-20170518-1443366e.tar.xz as it have driver for my wireless chipset 7615D.

The steps I did:

  1. Select Target system (MTK/Ralink APSoc (MIPS))
  2. Select subtarget (MT7621 based boards)
  3. There is no items under Target Profile so there is selected "Default Profile"
    After this I run "make defconfig", and then again "make menuconfig" to select nginx and other required software.

As at step 3 there is "Default Profile" selected I am not sure that some files like "WN3000RPV3.dts" being applied. Maybe I should create a Profile file for my router where Reset button should be described?

Yes, I have tried this link, but with no success.
I have tried actions described under sections "procd buttons" and "Hotplug Buttons" but didn't see any results with logread output.