Requesting build gives CORS error

I wanted to try building a custom image with additional packages but I get an error when clicking request build. I saw a topic that was fixed already.

Am I doing something wrong? I am new to openwrt.

nah, there's currently something wrong with the image builder.

1 Like

oh, ok. I'll try it at a later time then. Thank you for confirming.

Should I report a bug? (it's probably been reported?)
Should I mark your confirmation as a solution for this thread?

Thank you

it's been reported - The OpenWrt Firmware Selector - #640 by Lexeyko

that's up to you.

if you have Linux access, build the image yourself, it takes minutes -

1 Like

I do, I'll have a look and try to figure it out. Would be a useful know-how.

Thank you for the idea, that is definitely a solution.

cheers

assuming your Linux system fulfills the prerequisites

cd /whereever
wget https://downloads.openwrt.org/releases/23.05.2/targets/ath79/generic/openwrt-imagebuilder-23.05.2-ath79-generic.Linux-x86_64.tar.xz
tar -J -x -f openwrt-imagebuilder-*.tar.xz
rm openwrt-imagebuilder-23.05.2-ath79-generic.Linux-x86_64.tar.xz
cd openwrt-imagebuilder-*/
make image PROFILE=tplink_tl-wr1043nd-v2 PACKAGES="nano-full etherwake luci-app-wol ddns-scripts ddns-scripts-services luci-app-ddns"
cd bin/targets/ath79/generic/
ls
openwrt-23.05.2-ath79-generic-tplink_tl-wr1043nd-v2.manifest
openwrt-23.05.2-ath79-generic-tplink_tl-wr1043nd-v2-squashfs-factory.bin
openwrt-23.05.2-ath79-generic-tplink_tl-wr1043nd-v2-squashfs-sysupgrade.bin
profiles.json
sha256sums
1 Like

oh, thank you so much for the commands. I gave it a try but I have to test it on the router. I am currently on the latest version supported, will I brick the device if I override with the sysupgrade although it's the same version (except added packages)?

No, you can "upgrade" without actually upgrading.

1 Like

I'll try it in the coming days. Thank you again

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.