Request help for a new network configuration with DSA

same request help for a new network configuration with DSA: ( OpenWrt in switch managed mode )

my network file


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda6:afb8:17ab::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.251'
	option gateway '192.168.0.1'
	option delegate '0'
	list dns '192.168.0.1'
	list dns '192.168.1.1'
	list dns '8.8.8.8'
	option igmp_snooping '1'
	option stp '1'
	option ifname 'eth0.1'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd4:5f:25:eb:09:80'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd4:5f:25:eb:09:81'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 1t 2t 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '100'
	option ports '1t 2t 0'

config interface 'TV'
	option proto 'none'
	option delegate '0'
	option ifname 'eth0.100'
	option stp '1'
	option type 'bridge'
	option igmp_snooping '1'


2 Likes

Another configuration but OpenWrt in router mode + switch managed

network file:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd44:0fde:a8b4::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.1'
	option gateway '192.168.0.1'
	option delegate '0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'd4:5f:25:eb:09:80'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	option delegate '0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'
	option netmask '255.255.255.0'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd4:5f:25:eb:09:81'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 2t 3t 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 0'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '100'
	option ports '1 2t 3t'

config interface 'TV'
	option proto 'none'
	option ifname 'eth0.100'


Please add a screenshot of your current switch configuration page (under 19.07 or other pre-DSA / swconfig image) in Luci, and I will try to help reproduce the same setup under DSA. I know the definition is also under the switch parts of the config file, but it's difficult to see exactly which ports are available, and how they are setup. The graphical overview of the switch page is much nicer IMO :slight_smile:

1 Like

The concept of DSA is to make it seem to the user that the ports work independently, even though there is a hardware switch.

Each port has a unique name like 'wan', 'lan1', 'lan2' etc. These are supposed to match the manufacturer's name marked on the case but may not always.

Including a port name in a network (list ifname 'lan1') causes the port to send / receive untagged packets. Including a port name with a VLAN number (list ifname 'lan1.100') causes the port to send / receive tagged packets.

So to send tagged packets for the two networks to the SG108E switch would be lan4.1 in the lan config, and lan4.100 in the TV bridge.

config interface 'tvbridge'
    option type 'bridge'
    option proto 'none'
    list ifname 'lan1'
    list ifname 'lan4.100'

Here you're receiving untagged packets from the ONT on port lan1 then tagging them 100 to send out on the trunk cable from lan4.

2 Likes

Sorry but i have no ONT

1 Like

The Livebox then, the ISP box that is providing untagged TV packets on a second port.

The Livebox ... cannot work in Bridge.
There is therefore no need to talk about ONT in the configuration.
All the ports of the LIvebox send the normal stream for the Internet as well as the TV streams

In my case I bypass the router functionnality for the TV which will then be redirected correctly to the TV box by the SG108E

I already had a lot of trouble getting this configuration to work ... so if now the DSA is added

Please post a screenshot of the switch page of your current swconfig setup, and I can try to help you create a DSA configuration for the same setup.

root@OpenWrt-251-Managed:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fda6:afb8:17ab::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.0.251'
network.lan.gateway='192.168.0.1'
network.lan.delegate='0'
network.lan.dns='192.168.0.1' '192.168.1.1' '8.8.8.8'
network.lan.igmp_snooping='1'
network.lan.stp='1'
network.lan.ifname='eth0.1'
network.lan_eth0_1_dev=device
network.lan_eth0_1_dev.name='eth0.1'
network.lan_eth0_1_dev.macaddr='d4:5f:25:eb:09:80'
network.wan_eth0_2_dev=device
network.wan_eth0_2_dev.name='eth0.2'
network.wan_eth0_2_dev.macaddr='d4:5f:25:eb:09:81'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[0].ports='6t 1t 2t 3 4'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].vid='100'
network.@switch_vlan[1].ports='1t 2t 0'
network.TV=interface
network.TV.proto='none'
network.TV.delegate='0'
network.TV.ifname='eth0.100'
network.TV.stp='1'
network.TV.type='bridge'
network.TV.igmp_snooping='1'

Again, can you please screenshot the switch page in Luci? This contains the same information as the network file already does in the first post. It's a bit difficult to see how the ports are laid out on the switch by looking at the config file. The switch page displays this much more clearly.

I assume port 1 is the Livebox and port 2 is the SG-108E.

So the Livebox is using tagged packets to differentiate TV from Internet.

In that case you would only need one cable from the Livebox to your router, and it would access both VLANs with tags.

This defines a software bridge with only one member, and no protocol. Thus, it does nothing useful. The TV traffic is being switched by hardware in the swconfig.

Many thanks friend mk24

yes for th SG108E
the port 1 is VLAN 0 + VLAN 1
the port 2 is for the TV
the port 3 to 8 for internal network

If i have a little time i test this night with only one cable between Livebox and .WR1200JS and old 17.07.5 openwrt version

This screenshot should be pretty easy to setup. You'd want to create TWO bridge interface (one for each VLAN):

The first bridge contain should contain these interfaces:
lan1.1 + lan2.1 + lan3 + lan4

Explanation why: It's a VLAN with id "1", tagged on port 1 & 2 (so dot notation), and untagged on port 3 & 4.

The second bridge should contain these interfaces:
lan1.100 + lan2.100 + wan

Explanation why: It's a VLAN with id "100", tagged on port 1 and 2 (so dot notation) and untagged on the wan port.

Thanks Mushoz

OK for tagged Lan_x "point" & VLAN number

Ok for untagged only Lan_x without point & VLan number

For port not connected "nothing"

network file:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:t'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '100'
	list ports 'lan1:t'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.0.162'
	option gateway '192.168.0.1'
	option netmask '255.255.255.0'
	option delegate '0'
	list dns '192.168.0.1'
	list dns '8.8.8.8'
	list dns '192.168.1.1'

config device
	option type 'bridge'
	list ports 'br-lan.100'
	option name 'TV'
	option igmpversion '2'


Exactly :slight_smile: