Request for Stable Release 18.06.2 for NETGEAR R6120

First, I would like to say something interesting.

Though, the documentation on how to install OpenWrt on NETGEAR R6120, it is clearly stated that,

Currently, OpenWRT can be installed on the R6120 only by using the nmrpflash tool.

Yet, I quite easily installed OpenWrt on it through stock firmware upgrade web interface.
I did it twice on two distinct routers. Both worked like charm.

Thus, my humble request to the developers is, please release stable version 18.06.2 for NETGEAR R6120.

With best regards,

Usually service releases do not add support for new devices. You have to wait at least until the next release (19.x).

Yet the question remains, why the git commit says that flashing through OEM GUI is not possible, while you were able to install OpenWrt this way without any problems.


I exactly don't know why I succeeded, but all I did are as follows:
Kept pressing the reset button while powering up.
Plugged PC to router through LAN1 ( my PC's IP:, tried nmrpflash tool, and failed.
Became desperate and turned to Web UI to give it a try.
Uploaded Installation .img file.
Faced a warning that the selected firmware is backdated with respect to the existing one. Clicked to continue anyway.
It took a while...
I kept pinging on
The moment I got ping response, I logged into the OpenWrt. Configured and Connected to the Internet.
Executed sysupgrade with sysupgrade-bin file.
It took another a while.
I kept pinging once again.
Got ping response and logged into the OpenWrt once again.
Configured overlay to USB, and fine tuned a few stuff.

That's it - I mean - Voila!

Source and the actual name when uploaded?

I, first, downloaded

and uploaded the same.


1 Like

I know this is an old thread and I am a complete novice, but thought I'd share that the install worked for me too, using the netgear router's stock firmware updater. I didn't have to do anything out of the ordinary, just uploaded it like a typical netgear firmware upgrade and it worked pretty quickly. I had issues using the nmrpflash as well, though I'm sure that was user error because I've never done anything like this before. I also did the sysupgrade. Here are the files I downloaded and used. I didn't use the snapshot files like OP. I'm not exactly sure what the difference is with the snapshot versions or if that matters.

I also ran across this kernel file while searching R6120 and am curious what it's for, if it's something I should be installing somehow. If anyone has any insight, I'd appreciate it.

I still haven't been able to successfully set up the router as an extender, but I'm on my way. I did install one travelmate package, thinking that would help:
But I was not able to install this LUCI app companion:
I'm not able to use the travelmate features. I'm only working in LUCI. I'll keep plugging away trying to figure all this out though. I thought that sharing that the stock firmware install worked for me may help someone. If not, sorry for bringing up an old thread. Like I said, I'm very much a novice. But I have learned a great deal in the past two days and I appreciate everyone who works on these projects and shares all the information and knowledge that's available on this site.