Request for help with first install of OpenWrt snapshot on a Fritzbox 7530

Honestly, I currently have NO clue how to build my own snapshot image (I know you provided a link, thx) - that will come next :-).

And I even see dsl0 in the devices section wahoooo. I'm just a little concerned that in the interface section it's stated "network device is not present" :smirk:

So... what's up next? I suppose getting the modem up and running? Afterwards changing the interfaces from DHCP client to DHP server? Make a nap?

Which ISP are you customer of, and in which country?

Also, after you installed/copied the /lib/firmware files did you restart the 7530?

You are right - didn't think of the drivers :roll_eyes:. But I thought of them before reading your post :partying_face:- box is restarting at the moment. Country = Austria, provider = A1/Telekom

Okay... didn't work... what the fish? It worked with v22.0.3 (at least after installing the drivers, not showing in the device section, but at least not complaining that the device is not present :thinking:

Do I have to configure routing as well?

It looks like you need to use VLAN tag 2 for A1, see here:

What does dmesg show an wha ifconfig?

Currently I'm struggling with VLANs... Has that changed from 22.03.3 how to set this up? Can't get there (managed it in 22.03.3 though):

I think the FB7530/7520 installation instruction has valid advice for VLANs on these, see "VLAN setuo" on:

Note the section starting with:
" When configuring the VLANs it is very important to bind the LUCI network interfaces to the correct physical interfaces before applying the settings. Otherwise you will be locked out of the device and need to reflash it!"

And this:
"It has been mentioned in the forums that with this SoC, VLAN IDs 1 and 2 are treated specially by the hardware driver ([solved] VLANs on ipq40xx alternative config (for Fritzbox 4040) - #6 by aboaboit) so it is probably best to avoid VLAN ID 1 and 2 if possible. This may change with updated hardware drivers."

otherwise things go boink...

Yeah, struggling with that... Okay, the default LUCI installation misses the "switch" menu :rofl:

No I think that went away with swconfig, this is the new DSA way, and that is going to stay, swconfig is dead... but the instructions on the install page are still fine, at least they worked for me :wink:

my headache gets worse by the minute. I think in the past I also gave up with VLANs, but not this time...

So am I right that in the LUCI->Network->Interface I have to add lan1, lan2, etc first:

Pfft, honestly I was almost lost with the VLAN/switch stuff... and now that's gone... :worried: :weary:

what does your /etc/config/network look like pls? maybe that helps me?

Why do you need/want VLANs anyway? If just for the DSL interface, that will not need any switch configuration...

I can post that later, currently I am not at my modem....

Thanks, great. Good question ad VLANs. I think at the moment I do not NEED them, but when trying to get the fritzbox 7530 running under 22.03.3 I also got the error message "Network device is not present" for the dsl0.2 interface. and if I remmber correctly I solved it by some VLAN magic like in the post you ale refered me to:
image

VLANs for the dsl port do not require VLANs on the switch ports.

I might start understand this thing a little bit...
Doesn't it make sense that dsl0.2 (a VLAN "to" (is that the right diction?) device DSL0) REQUIRES a VLAN? Otherwise it makes sense that it thinks there is no network device present?

Edit: that's why it "worked" when i VLANed it under 22.03.3 (altough not completely as the drivers were not compatible?).

Edit 2: no I "just" need to know the syntax of the /etc/config/network section to switch... what - thats the question :slight_smile:
config 'switch_BLABLABLA' 'wan'
option 'device' 'dsl0'
option 'vlan' '1' (you and the guide said to avoid 1 and 2 - so maybe 7?)
option 'ports' '???' (no clue here)

root@OpenWrt_FB7520:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcd:4cf3:765d::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option tone 'b'
	option annex 'b'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ip6assign '60'
	option device 'br-lan.42'
	list ipaddr '192.168.100.1/24'

config device
	option name 'dsl0'
	option macaddr '98:9B:CB:C0:F5:BB'

config interface 'wan'
	option device 'dsl0'
	option proto 'none'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '42'
	list ports 'lan1:t'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '7'
	list ports 'lan1:t*'

config device
	option type '8021q'
	option ifname 'dsl0'
	option vid '7'
	option name 'dsl0.7'

config device
	option type 'bridge'
	option name 'br-dsl'
	list ports 'br-lan.7'
	list ports 'dsl0.7'

config interface 'MODEM'
	option proto 'none'
	option device 'br-dsl'

this is my configuration, which:
a) does not contain a functioning wan section (on purpose)
b) does contain a VLAN definition for the dsl interface:

config device
	option type '8021q'
	option ifname 'dsl0'
	option vid '7'
	option name 'dsl0.7'

it is just that in Germany many Telekom links use VLAN7 instead of VLAN2 as with A1.
c) is configured for 192.168.100.1
d) bridges port lan1.7 (in its instance as br-lan.7) with dsl0.7; my main OpenWrt router is connected to lan1 and uses VLAN7 to reach the internet throu the modem's br-dsl bridge
e) the router is also accessing lan1.42 so the lan side of the modem, so I can look at the DSL statistics.

I am pretty sure you want/need none of this, but since I posted my working config, I wanted to describe/explain a few things so that it might actually be useful.

P.S: I know that this contains a MAC address, but I am fine with that, I do not consider that to noticeably increase my risk of anything...

Yes in that name dsl0.2 the .2 denotes VLAN2 on interface dsl0.

BTW, instead of posting screen shots of terminal output, just copy and paste as text and put it between
two rows of backticks (`) like:
```
copied text
iiiiiiiiiii
```
which will ten be rendered nicely like:

        copied text
        iiiiiiiiiii

note how this uses a fixed width font which is great for terminal output.

Thanks for all - I'll try it. One more question for the time being: do you need to provide a username/pass? I copied parts of your /etc/config/network (obviously you have a Fritz!Box 7520 :upside_down_face: that should be quite similar to mine) but unsure where to put my username/pass in...
From what I got using your config is:

No I have an unmanaged protocol for the modem...

config device
        option type '8021q'
        option ifname 'dsl0'
        option vid '2'
        option name 'dsl0.2'

config device
        option type 'bridge'
        option name 'br-dsl'
        list ports 'br-lan.2'
        list ports 'dsl0.2'

config interface 'MODEM'
        option proto 'none'
        option device 'br-dsl'

"Unfortunately", your config is slightly different then the one provided here:

config interface 'wan'
        option proto 'pppoe'
        option username '...@t-online.de'
        option password '...'
        option ipv6 'auto'
        option ifname 'eth0.7'

ty

On my primary router that is connected with its eth2 interface to the modem's lan1 port:

config interface 'wan'
	option hostname 'turris'
	option ipv6 '1'
	option proto 'pppoe'
	option username 'USERIDENTIFIER'
	option password 'MYSECRETPASSWORD'
	option force_link '1'
	option device 'eth2.7'

so yes I need to supply a username and password, and with my ISP these need to be correct, but e.g. Deutsche Telekom who operates the link allows their users to use empty or arbitrary values for username and password, since they can identify the actual link and hence know who ordered the link. So my redacted username and password above, would actually work if I was a Telekom customer.... :wink:

That would be in the wan section, but as I said my bridged-modem does not have a working wan section, since I do not want it to reach the internet in the first place....

Well, as I tried to explain, my configuration is not for using the 7520 as full modem router, but to use it as bridged modem only in combination with a "real" router. That is unlikely to be what you want for your network or you would have asked different questions :wink:

But as you see above on my "real" router the wan section looks pretty much like in the recommendations you linked.

A1 uses two different set ups in Austria. One is PPPoE on VLAN2, that is the newer configuration. The older ADSL connections use a different syntax. Are you on VDSL?

You do not need to set up any bridging or any VLANS. Just change the the device of interface pppoe to vlan0.2 and you're good to go! In LuCI, you might have to type dsl0.2 as it's usually not present.

Posting this from my Fritz!Box 7530 openWRTed... party time

image

Man, you made me glad! Thanks a lot for all the help! HIGHLY appreciated! Now I just have to reconfigure the LANs (to DHCP server) and hope not to loose connection :-). Be "right" back... in a few hours