Report Devices Here With 18.06.0 Provided Image too big to save overlay

Also reporting DLink DIR-300 B5 with 18.06.1 r7258-5eb055306, flashed through emergency

At least the setting do not survive reboot and there's no overlay mounted

The LUCI System->Software says: Free space: 0% ( 0.00 B )

root@OpenWrt:~# cat /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    13.8M    568.0K     13.2M   4% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:~# ls -lisa /overlay
    419      0 drwxr-xr-x    2 root     root             0 Aug 16 07:51 .
      1      0 drwxr-xr-x   16 root     root             0 Jan  1  1970 ..
root@OpenWrt:~# logread|grep overlay

Packages list:

root@OpenWrt:~# echo $(opkg list_installed | awk '{ print $1 }')
base-files busybox dnsmasq dropbear firewall fstools fwtool hostapd-common ip6tables iptables iw iwinfo jshn jsonfilter kernel kmod-cfg80211 kmod-eeprom-93cx6 kmod-gpio-button-hotplug kmod-ip6tables kmod-ipt-conntrack kmod-ipt-core kmod-ipt-nat kmod-ipt-offload kmod-leds-gpio kmod-lib-crc-ccitt kmod-lib-crc-itu-t kmod-mac80211 kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-flow kmod-nf-ipt kmod-nf-ipt6 kmod-nf-nat kmod-nf-reject kmod-nf-reject6 kmod-ppp kmod-pppoe kmod-pppox kmod-rt2800-lib kmod-rt2800-mmio kmod-rt2800-soc kmod-rt2x00-lib kmod-rt2x00-mmio kmod-slhc libblobmsg-json libc libgcc libip4tc libip6tc libiwinfo libiwinfo-lua libjson-c libjson-script liblua liblucihttp liblucihttp-lua libnl-tiny libpthread libubox libubus libubus-lua libuci libuclient libxtables logd lua luci luci-app-firewall luci-base luci-lib-ip luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-proto-ipv6 luci-proto-ppp luci-theme-bootstrap mtd netifd odhcp6c odhcpd-ipv6only openwrt-keyring opkg ppp ppp-mod-pppoe procd rpcd rpcd-mod-rrdns swconfig ubox ubus ubusd uci uclient-fetch uhttpd usign wireless-regdb wpad-mini

Not sure what can I omit from here using the image builder )

The history: (just for whining)

A friend flashed it for me (can't remember the version, but he did it like 1-3 months ago, seems like it was 17), then I've found out that it doesn't save the config and boots into default config including passwordless root login on all interfaces.

So, I've flashed 15.05.1, since it was on the OpenWRT wiki for the device a month ago (I was lost in architectures and download links and didn't want to risk bricking the router). The config survived reboot, but I've just installed a fresh xubuntu 18.04.1 onto my laptop and it was working ok for half an hour and then started losing connection once per minute both through wifi and ethernet, also lost the connection on eth so it couldn't even get an ip. I thought it could be because of an old firmware. (Seems like it was not the firmware, because it still doesn't connect and the windows box works ok, so did the ipad and iphone/androids)

I've watched the logs on the router and detected that it was sending dhcp handshakes to the laptop. Nevertheless I decided to upgrade the firmware and flashed the new 18.06.1 (the new link is in the wiki today).

The list was getting rather long, so I have made a separate wiki page for all the tips about how to shrink the firmware and save RAM:

1 Like

It happens also on Buffalo WZR-HP-G300NH (32M flash, 64M RAM) with 18.06.1 downloaded image

You might have similar symptoms, but at 32 MB flash it's impossible that the release images would be too large - so that would need debugging (and a different thread).

thank you
I've opened a new thread:

D-Link dir-645
seems to be affected, see my post D-Link dir-645: Cannot save any configuration changes in LUCI

My Sitecom WL-351 version v1.002 seems to have the same issue. LEDE 17.01.5 works fine.

Should not be affected, your device is 8 MB. See your post.

I have a Linksys WAG54G2 router, does it support OpenWRT, I need this firmware to repeat my friends wifi with me. Please help. thanks.

This is the wrong thread for that question, just by reading the title.

Flagged your post.

@zifnaz No, Current versions of OpenWrt do not support your WAG54 router. According to the Table of Hardware[Model*~]=WAG54 the newest firmware will not work, both because it has limited RAM/Flash, and because it has not seen an update to the firmware since version 10.03.1.

TP-Link TL-WR840N v5, overlay is mounted on tmpfs.

Not sure if this is the right issue since there's no older version to check this on, but I have a TP Link TL-WA850RE v2 with amnesia.

The TP-Link TL-WR2543N/ND v1 should have 8 MB flash, while not plenty, it's still more than sufficient for a full featured OpenWrt release, it doesn't need a tiny variant. If there are problems with mounting the overlay, there will be other reasons that need to be debugged.

Thanks for your report, but it would be more helpful if you tell which router you are using.

TP-Link TL-WR2543ND v1.0

It has 8 MB flash, so the problems must be caused by something other than the image being too big. If you create a new topic and post the boot log then maybe someone can help you.

1 Like

Sorry, problem was with router. Maybe bad flash chip, don't know. I've second router, flashed it with 18.06.1 and everything works.

Seems like a partitioning problem.

Thank you for sharing this! I have the same problems with the same hardware. I'm using a Viasat custom version of Netgear WNR612v2 (called WN602v2, yes, no R). I understand it's the same hardware as WNR612v2 but without a RJ45 connector for WAN, which I of course soldered to the board myself. Netgears own firmware for WNR612v2 works flawlessly, so it really can't be any other major differences.

It's wonderful to have all the openwrt capabilities and performance, but I can't get anything above 14.04 to work. I have tried factory img-files, and sysupgrade bin's, but with no success. I get kernel panic at different points during the boot process, either a sync problem or "can't mount". Too advanced for me, but I'd be happy to share logs from serial port if of any use. Using TFTP the router is easily restored to 14.04 every time, but it would be great to be able to run 18.06.1. I realize this is limited hardware, but I'm grateful for any help.