Replacing Router, but no internet access

Hello,
So I had everything working with my TP-LINK archer C2600 router hanging off another wireless router, with the LAN on 192.168.2.1. I went to replace the other router with the TP-LINK, I put the LAN on 192.168.1.1, powered off, swapped cables with the other router and....nothing. It actually messed up the password somehow so I had to figure out how to restore that. Finally got it back and running, but I can't get internet access.

I'm guessing somewhere in the firewall, but this stuff is confusing me right now.

I'm using a TP-LINK archer C2600, running "OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01"

Thanks in advance!
Here are my files:

NETWORK:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.99.99'
        option netmask '255.255.255.0'

WIRELESS:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'xxxxxxxx'
        option ssid 'larry_5g'
        option encryption 'psk2'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'larry'
        option key 'xxxxxxxx'
        option encryption 'psk2'

config wifi-iface 'wifinet2'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option isolate '1'
        option key 'xxxxxx'
        option network 'guest'
        option disabled '1'
        option ssid 'larry_5G_Guest'

DHCP:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'guest'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'guest'

FIREWALL:

config defaults
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option input 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan6 wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'guest'
        option forward 'REJECT'
        option network 'guest'
        option output 'ACCEPT'
        option input 'REJECT'

config rule
        option target 'ACCEPT'
        option src 'guest'
        option name 'Guest DNS'
        option dest_port '53'
        list proto 'tcp'
        list proto 'udp'

config rule
        option src 'guest'
        option name 'Guest DHCP'
        option target 'ACCEPT'
        option dest_port '67'
        list proto 'tcp'
        list proto 'udp'

config forwarding 'guest_wan'
        option src 'guest'
        option dest 'wan'

1 Like

What is the output of ip 4 addr; ip -4 ro ?

1 Like

hey trendy, thanks for the help!
I'm not sure if I need to have my router in situ, but it's just powered up by itself right now with a laptop on its LAN port.

at any rate, I got some blurb about usage and then this:
"192.168.1.0/24 dev br-lan scope link src 192.168.1.1"

What's that all mean?
Thanks!

It looks like the WAN interface is not connected/configured.
Make sure the WAN link is up and the upstream router is distributing DHCP.
Try to restart the upstream router if possible.
Otherwise try to clone the WAN MAC address to the same as the old one.

1 Like

Hey vgaetera!
So, I'm getting messed up with terminology, so just to make sure we're on the same page...
My tplink is just by itself right now, it's not connected to the cable modem (ultimate goal) or the old Asus wireless router (the router it's going to replace hopefully). When you helped me yesterday, I had its WAN port connected to the LAN port of the Asus.

I can put the tplink lan interface back to 192.168.2.1 and then plug its WAN into the LAN of the asus again, if that is helpful, but I was thinking since I went from that setup to plugging it into the cable modem (after changing LAN to 192.168.1.1), it wouldn't be helpful.

So, on your final comment, do I understand I should go into the asus router, copy its MAC address and put it in the tplink's MAC?

Thanks!

That's it, if restarting the modem doesn't help, then copy WAN MAC from the old router.

2 Likes

It isn't necessary to use 192.168.1.1 as a main router, you can leave it at 2.1 as long as the wan IP from the cable modem is not in that range. Depending on its operating mode, a cable modem will usually give a"public" IP issued from the cable company DHCP server, or an IP in the 192.168.100.0/24 range, so that is fine.

If you are bridging through the cable modem (wan IP is public) the cable company usually has a waiting time before it will serve a new router on your end. Power off the cable modem and leave it off for 30 minutes, then boot up the modem connected to the new router at the same time.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.