Repeater working but no internet

Hi guys,

I've been trying for a few days now to setup my device to act as repeater. I followed this article to get my devices to to talk to another and so far that's working. My only problem left being that my android devices tell me i have no internet connection and disconnect immediately.

I wouldn't be surprised if there's some firewall stuff that I'm overlooking but there are to many trees for me to see the forest.

network
config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'
	list network 'wwan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option dest_port '22'
	option src 'wan'
	option name 'Allow-SSH'
	option target 'ACCEPT'
	list proto 'tcp'
	list src_ip '10.10.10.0/24'

config rule
	option dest_port '443'
	list proto 'tcp'
	option name 'Allow-HTTPS'
	list src_ip '10.10.10.0/24'
	option target 'ACCEPT'
	option src 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option input 'ACCEPT'
	option output 'ACCEPT'
	option name 'GL_2_LAN'
	list network 'GUEST'
	list network 'gl_rpt_bridge'
	list network 'wwan'
	option forward 'ACCEPT'
	option mtu_fix '1'
	option masq '1'

config forwarding
	option dest 'lan'
	option src 'GL_2_LAN'

config forwarding
	option dest 'GL_2_LAN'
	option src 'lan'
firewall
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdda:78f0:3f5b::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option type 'bridge'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr 'd8:47:32:52:6b:1b'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

config interface 'wwan'
	option proto 'dhcp'
	option delegate '0'

config interface 'GUEST'
	option proto 'static'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'
	option type 'bridge'
	option delegate '0'
	option igmp_snooping '1'
	list dns '192.168.4.1'

config interface 'gl_rpt_bridge'
	option proto 'relay'
	list network 'GUEST'
	list network 'wwan'
	option delegate '0'

config route
	option target '192.168.4.0'
	option gateway '192.168.4.1'
	option interface 'GUEST'
	option netmask '255.255.255.0'
wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option country 'DE'
	option channel '10'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option bssid '04:F0:21:86:50:04'
	option key 'xxx'
	option mode 'sta'
	option ssid 'toberepeated'
	option encryption 'psk2+ccmp'
	option network 'wwan GUEST'

config wifi-iface 'wifinet2'
	option encryption 'psk2+ccmp'
	option device 'radio1'
	option mode 'ap'
	option key 'xxx'
	option ieee80211w '2'
	option hidden '1'
	option ssid 'toberepeated'
	option network 'GUEST'

Any ideas what I'm missing?

This route is not needed. Remove it.

The dns in GUEST interface is not correct, remove it.
The relay interface is not covering the lan, only GUEST and wwan. GUEST won't be separated from lan if they are both members of relay. wifinet1 is assigned to wwan and GUEST, remove the GUEST.
gl_rpt_bridge is not member of lan firewall zone.
GL_2_LAN zone has mtu_fix and masquerade enabled.
I would suggest to start from scratch and don't use guest interface.

1 Like