Repeated disassociations and disassoc_low_ack has no effect

I am using a @davidc502 build of OpenWrt on my WRT1900ACS. One of the clients that connects is disconnected every 5 minutes with reason "disassociated due to inactivity" when it is not active (transferring data). I have unchecked 'Disassociate On Low Acknowledgement' (aka set disassoc_low_ack to 0) but nothing has changed.

Thu Jun 11 02:17:43 2020 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Thu Jun 11 02:17:43 2020 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 1)
Thu Jun 11 02:17:43 2020 daemon.notice hostapd: wlan1: AP-STA-CONNECTED xx:xx:xx:xx:xx:xx
Thu Jun 11 02:17:43 2020 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (WPA)
Thu Jun 11 02:17:43 2020 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx WPA: group key handshake completed (WPA)
Thu Jun 11 02:22:57 2020 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED xx:xx:xx:xx:xx:xx
Thu Jun 11 02:22:57 2020 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: disassociated due to inactivity

In disassoc_low_ack documentation it says "This depends on the driver capabilities and may not be available with all drivers."

Does anyone have that option working on a WRT1900ACS or similar router? I think next I will try increasing max_inactivity to 10 minutes to see if that setting has any effect.

1 Like

It seems like I have the same issue on Linksys WRT3200ACM, Im now on 21.02.0-rc3 and I think the issue started when I upgraded to 21.02 .

I could read here Nest Protect disassociated due to inactivity - #6 that it could be related to DNSSEC, as I have stubby + dnsmasq for dns over SSL , I am thinking it could be related to that, so I changed the DNSSEC validation to enforced according to https://openwrt.org/docs/guide-user/services/dns/dot_dnsmasq_stubby
I still see disconnects in the logs.

I don't think this max_inactivity helps, otherwise, we could set it to 1 month if it has effects.

adblock was not the issue, I'll try removing dns over tls and if that doesn't help will fall back to stock firmware.