Repeat netbios name to local DNS, possible?

My setup: I have an openwrt (latest version) router acting as a Samba server and an Openvpn server behind my ISP router (part of the terms of services, all ISPs do that where I live).
What I am lookig for:

  1. Redirect the DNS server adresses on the ISP router to my local DNS. (DHCP server is running on the ISP router).
  2. A local DNS running on my openwrt router that adds a few names (no ".lan" stuff) but redirect everything else to public DNS on internet
  3. Repeat the netbios info from windows stations to my local DNS for openvpn clients

Is this all possible and if yes, please kindly direct me to the proper ressources as I am quite a beginner in the area of DNS stuff. NB for LAN all I need is IPv4.

Do you have some devices connected directly to ISP router and some to the OpenWrt router? Or do all of the devices connect to OpenWrt router only and the OpenWrt router itself is the only device connected to the ISP router?

No it is not possible. You have to shut off the DHCP server on the ISP router. The only DHCP server that can be answering queries is the one on the openwrt router and that would then hand out it's own IP address as the DNS server.

You can't repeat netbios names to a DNS server. But all windows clients on boot attempt to register their names into whatever the DNS server is and if that server is configured to allow registration you will be OK

But I think you have a lot of other misunderstandings of what is going on here. For starters you are running a "double translation" system. Your ISP router translates to private numbers and then your openwrt router translates from the ISP routers private numbers to the openwrt router's private numbers. What it sort of sounds like is you want machines on the private ISP network and the private OpenWRT network to be able to talk to each other.

More information on what you are trying to accomplish is needed. For example are you running port forwards on the ISP router?

I forgot to mention that my openwrt router does not NAT as it acts as a pure LAN server (much alike a linux or windows box) . The configuration is much like a "dumb AP". There is only one port forward from the ISP router to my openvpn server. Although I can disable the DHCP server from the ISP router, I would prefer to make it point to my own DNS server instead. My utlimate goal is to be able to acces my home computers by name when on the road using openvpn client. I am just looking to "beef up" the DNS function.
p.s. and eventually do some site blocking based on specific computers...

All devices are conneted to the ISP router. The openwrt router just acts like a switch when I need more ports

I am still in need of a better beginner guide. All the ones I have seen assume openwrt as the master router which is not the case for many openwrt users like me in the field. Also, it is unclear as of how the windows machines register their networks names to the local DNS (which my ISP router ignores). As a reference here is the configuration of my test router:

{
        "kernel": "5.15.150",
        "hostname": "gl-ar750s",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "GL.iNet GL-AR750S (NOR/NAND)",
        "board_name": "glinet,gl-ar750s-nor-nand",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ath79/nand",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config device
        option name 'eth0'
        option ipv6 '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 3 2 1'
        option vid '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option proto 'dhcp'
        option device 'br-lan'
        option delegate '0'

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'