Remove prompt at boot?

So ive been tinkering with openwrt in VMs for a while to get familiar with it.
Today i got my hardware, and one thing is different, and i have no idea why.

If i reboot it, i have to connect a keyboard to it and press enter.
When i did it in a VM it continued to boot after 5sec, why is it different now?


What "hardware" did you get?
If I remember correct even x86 images do not support keyboards out of the box. So its probably not OpenWrt related.

I would guess it is related to your system. Concrete I would say it is bios/uefi related.
The system simply stops if there is a certain hardware missing (mostly gpu). You can disable that in bios/uefi. Consult your manual of the mainboard.

1 Like

Yeah probably is hardware related.
I got a Qotom Q570G6

Its not a "BIOS message" tho, its the usual "OpenWRT" and "OpenWRT (failsafe)" prompt. But there is no 5seconds countdown and then autoselect, hmmm

Hmm... Indeed. Well I have no idea why it does not auto boot. Sorry.

think it's something to do with the serial/console line near the top of grub.conf... try a forum search for 'grub keyboard' or you could mess with the ps2 emulation / usb legacy etc. settings in your bios... maybe setting timeout to zero might work too...


Also see: [SOLVED] Serial Port RS-232 - Securing console and preventing lockout

1 Like

If your hardware does not have a serial port, you need to modify the GRUB configuration so it does not try to use serial.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.