Klingon
1
Hi everyone,
Each time I reboot my AP (DAP-2610) I get an "auto-generated" default route:
root@DAP2610:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.10.1 0.0.0.0 UG 0 0 0 br-lan10
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan10
I'm not interested in the auto-default route and after booting:
root@DAP2610:~# ip route del default
Result:
root@DAP2610:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan10
Is there any way not to auto-create the default gw each time I reboot the device?
I suppose modifying /etc/rc.local
and adding ip route del default
should work, but I prefer another option.
Thanks for your time and help,
egc
2
The interface (WAN) has a setting "Use Default Gateway" under Advanced settings.
Disable that and restart network (service network restart)
Klingon
3
Hi @egc
Thanks for your help, but DAP-2610 is a single port device, no WAN interface is present.
trendy
4
You can do that on the lan10 device or whatever device is installing the gateway.
1 Like
Klingon
5
I think is already done in my config:
root@DAP2610:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix xxxxxxxxxxx'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan'
config device
option name 'lan'
option macaddr 'xxxxxxxxxx'
config interface 'lan'
option proto 'static'
option ipaddr '192.168.1.5'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
list dns '192.168.1.1'
option device 'br-lan'
option delegate '0'
config device
option name 'br-lan10'
option type 'bridge'
list ports 'lan.10'
config interface 'vlan10'
option device 'br-lan10'
option proto 'static'
option ipaddr '192.168.10.5'
option netmask '255.255.255.0'
option gateway '192.168.10.1'
list dns '192.168.10.1'
option delegate '0'
config route
option interface 'lan'
option target '0.0.0.0/0'
option gateway '192.168.1.1'
option table 'default'
option source '192.168.1.5'
config route
option interface 'vlan10'
option target '0.0.0.0/0'
option gateway '192.168.10.1'
option table 'default'
option source '192.168.10.5'
root@DAP2610:~#
trendy
6
Not really, delete the gateways from the interfaces as well as the 2 routes.
Klingon
7
Thanks @trendy and @egc now is working!!!
root@DAP2610:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan10
root@DAP2610:~#
system
Closed
8
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.