Relayd - works but the router itself can't reach the internet

Hello!
I have a router setup as a wifi repeater with relayd as described here and it works correctly, i.e. I can connect to the repeater AP and have internet.
The issue is that I can't do things like update the package list, or ping domains from the router's shell, as if it wasn't connected to the internet.
I'm guessing I have something to change in my interfaces, but to be honest I'm a little lost here. Please help :slight_smile:

/etc/config/network (hope it helps, I can provide more details)

config interface 'loopback'                                                                                                                                                                    
        option ifname 'lo'                                                                                                                                                                     
        option proto 'static'                                                                                                                                                                  
        option ipaddr '127.0.0.1'                                                                                                                                                              
        option netmask '255.0.0.0'                                                                                                                                                             
                                                                                                                                                                                               
config globals 'globals'                                                                                                                                                                       
        option ula_prefix 'fdbd:8db8:7bb5::/48'                                                
                                               
config interface 'lan'                         
        option type 'bridge'                                                                                                                                                                   
        option ifname 'eth0.1'                 
        option proto 'static'                  
        option ipaddr '192.168.1.1'            
        option netmask '255.255.255.0'         
        option ip6assign '60'                  
        option gateway '192.168.0.1'                                                           
        option dns '192.168.0.1'               
                                               
config device 'lan_eth0_1_dev'                 
        option name 'eth0.1'                   
        option macaddr 'b0:4e:26:4b:3e:31'     

config interface 'wan'                         
        option ifname 'eth0.2'                 
        option proto 'dhcp'                    
                                               
config device 'wan_eth0_2_dev'                                                                 
        option name 'eth0.2'                   
        option macaddr 'b0:4e:26:4b:3e:32'     
                                               
config interface 'wan6'                        
        option ifname 'eth0.2'                 
        option proto 'dhcpv6'                  
                                               
config switch                                  
        option name 'switch0'                  
        option reset '1'                       
        option enable_vlan '1'                 
                                               
config switch_vlan                             
        option device 'switch0'                
        option vlan '1'                        
        option ports '1 2 3 4 6t'

config switch_vlan                             
        option device 'switch0'                
        option vlan '2'
        option ports '0 6t'

config interface 'repeater_bridge'
        option proto 'relay'
        option ipaddr '192.168.0.2'
        list network 'lan'
        list network 'wwan'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.0.2'
        option netmask '255.255.255.0'

Thanks!

why do you need relayd? just set up a second AP for LAN#2
eg my network is like this
modem - router1(AP#1;LAN#1) - router2(AP#2;LAN#2)
my AP#2 is a DMZ but this is what I wanted.
no issue connecting any of the LAN (accordingly) and using opkg

You have wrongly configured them under lan interface, they should be under wwan

I tried changing the interfaces for the access poitns to wwan but it didn't help. I'm pretty sure I misinterpreted what you were suggesting though, as I understand little of what is going. I ended up going with @rpmoomin's solution, which is fine with me for the time being. I'll try again later, keeping that in mind, thank you.

Thank you! I hadn't even considered that. Being new to openwrt, it didn't occur to me that the router could simply use AP#1 as its WAN of sorts, but it makes a lot of sense. Plus it allows me to do traffic shaping & all...
I had to reset the router because just making the change, the setup worked but the router still had no internet... I'll figure it out later.

I meant this: