Relayd DHCP clients

Hi everyone,
I saw this topic being discussed multiple times on this forum, I've tested multiple different configuration and cannot make it work anymore.

I used to have the snapshot build installed and after some struggle, I could make it work. I have a TP-Link RE450 v3 running with 21.02.1, and it seems that with this build cannot make it happen anymore.

What is happening is that the clients connected to the LAN port won't get the IP assigned by DHCP. If I configure manually, I can navigate successfully.

DHCP, Firewall and DNSMASQ are disabled. I have this configuration for my interfaces:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd2a:8463:a18c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'

config interface 'bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wan'
        option ipaddr ''

Any suggestion? I appreciate your help. Thanks

Did you upgrade from snapshot to 21.02.1 and 'Keep Settings', and reinstall the relayd package, or did you start from scratch?

fwiw, as it is working with static IPs assigned to your devices, could it be the known problem where DHCP messages may not pass properly through relayd as posted at the top of the wiki page?
There's no solution as far as I'm aware other than changing make & model of access point (main router?) to see if it solves the problem?

Vaguely recall the last time it was investigated and posted on this forum several years ago, it was discovered a Zyxel router wasn't sending the correct type of DHCP message to the openwrt router running relayd. Sorry, don't have link or details.

What is the make and LAN IP of your access point (main router) ?

I made it from scratch. My bad. No backup from previous configuration either.
This device use AR8033 : [OpenWrt Wiki] TP-Link RE450

It can be related to what is reported here:, but I need to verify it.

Yeah, it's a usual problem with relayd setup. I first noticed it when my clients stopped receiving ip.

The only solution is to go static all the way. Or put this relayd setup behind another AP. Setting this AP with static ip, once done clients connected to this AP receive ip normally. Aside from double nat, everything else works just fine.

1 Like

Did this setup just before Christmas, last year.

Only thing I did was to make sure the host connecting, and running the relayd, got a static IP assigned from the main router.

Can you elaborate a bit more on that? You mean that you are using a reservation from your DHCP server? or that you've assigned a static IP on the WAN port?

Yes, the mac of the radio connecting to the main router (hosting the dhcp) always assigns the same ip to the relayd host.

I think an IP have to be provided during setup, and a random IP, didn't make much sense.

The wan port is never used.
The easiest way is to connect it to the lan ports with the switch as shown in the example

The configuration that I have indicated to you is used for a very long time 5 meters from me to manage USB printers (as there is only one port on the mt300, I have a small 4-port powered USB)
I also used sane for a small scanner LIDE20 Canon which does not have 64-bit windows drivers

This device have only one ethernet port. Maybe that is the cause of the issue here. Some misconfiguration. I see that the that the WWAN interface created while connecting to wifi, get a dynamic IP from DHCP. Apparently DHCP is not routed through the bridge adapter to the ethernet port.

I hadn't paid much attention because I'm replying to a similar post here at the same time:

Read this :

Take a good look at my example there is no address assigned by a dhcp. his address is

I say again for the WWAN

If you only have one port, then this is the lan and there is no wan.for wifi it's wwan

**You need to use stabridge -> opkg install luci-proto-relay **

1 Like