Regular PPP disconnects with OpenWrt 18.06.0 on lantiq-xrx200 hardware


I'm using the "O2 Box". I had no problems with 17.01.4. Now with 18.06.0 I have regular PPP hangups. The DSL connection seems to keep alive but even manual retry attempts fail.

DSL info:
Kernel log:

(Sorry for the disabled links. Seems like some silly forum configuration disallows me to post links)

I tried to "reconnect" the WAN interface which failed.
I tried to disconnect the DSL wire in hope a complete "reinitialization cycle" will fix this but this failed.

A reboot fixes this but the last time this hangup happened was just 2 hours ago.

I tried to go back to lede-17.01.4 but the new firmware doesn't take my old firmware image for flashing.

  • Is this a known bug?
  • How to get back to my 17.01.4 version?

I have to disconnect the OpenWRT router for now and connect some proprietary one.

You can downgrade from a command line ( ssh ) , use sysupgrade command with -F option to force.

it goes down after pppd: No response to 5 echo-requests

and then having problems to reconnect

daemon.warn pppd: Timeout waiting for PADO packets
daemon.err pppd: Unable to complete PPPoE Discovery

is this a known bug?

You can find multipe posts on failed Lantiq+PPPoE reconnects (pppoe-reconnection-failing-lantiq-built-in-modem). I'm not sure myself, but by checking out this commit openwrt/openwrt#555c5923 and its references higher tolerances with the LCP (link control protocol) echo might help to not disconnect in the first place by a missing echo: adjust lcp-echo-failure/lcp-echo-interval from their 5/1 default values fit for your ISP connection (5/5 helped one of the commentors) or set them to 0 in /etc/ppp/options to disable the echo failure modes. If you use a snapshot from after 01/2019 with the commit, passing option keepalive 0 in the config interface 'wan' section will disable the echos.

From my observation, disconnects happen when there's lots of throughput and 5 echos can go missing within 5 seconds. Reboots always helped to resolve the reconnection issue too.