redmiAC2100 ipv6 configuration problem

My redmi AC2100 is using 22.03 firmware: openwrt-22.03.0-ramips-mt7621-xiaomi_mi-router-ac2100-squashfs-sysupgrade.bin But no matter how I try to configure ipv6, I can't get the public network ip address, my computer shows that my ipv6 has no network access permission, I hope to get help from everyone to solve this problem

ok, let's check what you have configured, and what you're receiving on the wan6 interface.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board;
uci export network;
uci export dhcp; ip6tables-save -c; ifstatus wan6
ubus call system board
{
        "kernel": "5.10.138",
        "hostname": "LYB-Redmi",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Xiaomi Mi Router AC2100",
        "board_name": "xiaomi,mi-router-ac2100",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.0",
                "revision": "r19685-512e76967f",
                "target": "ramips/mt7621",
                "description": "OpenWrt 22.03.0 r19685-512e76967f"
        }
}

uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdfa:ed3c:xxxx::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.31.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

uci export dhcp
package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

ip6tables-save -c
-ash: ip6tables-save: not found
ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 706625,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2409:XXXX:XXX:XXXX::2",
                        "mask": 128,
                        "preferred": 106387,
                        "valid": 192787
                },
                {
                        "address": "2409:XXXX:XXX:XXXX:XXXX:XXXX:XXXX:XXXX",
                        "mask": 64,
                        "preferred": 106385,
                        "valid": 192785
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2409:XXXX:XXX:XXXX::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 192785,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1335,
                        "source": "2409:XXXX:XXX:XXXX:XXXX:XXXX:XXXX:XXXX/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1335,
                        "source": "2409:XXXX:XXX:XXXX::2/128"
                }
        ],
        "dns-server": [
                "fe80::1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "00170010fe800000000000000000000000000001"
        }
}

please try to assign IPv6-PD into the WAN6 interface by adding option reqprefix 'auto':

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
Or change it in Luci.

Also, if you're not going to downstream ipv6 after your LAN to another router, change

from '60' to '64'

or change it in Luci.

When the changes are made, but it doesn't help, please provide the output of the following command again (remember to redact any public IP addresses you may have):
ifstatus wan6
So we will be able to verify if IPv6-PD has been assigned to the WAN6 interface, and the size of IPv6 Prefix Delegation obtained from your ISP.

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 227,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "updated": [
                "addresses",
                "routes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2409:XXXX:XXX:XXXX::2",
                        "mask": 128,
                        "preferred": 116924,
                        "valid": 203324
                },
                {
                        "address": "2409:XXXX:XXX:XXXX:XXXX:XXXX:XXXX:XXXX",
                        "mask": 64,
                        "preferred": 116924,
                        "valid": 203324
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2409:XXXX:XXX:XXXX::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 203324,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1573,
                        "source": "2409:XXXX:XXX:XXXX:XXXX:XXXX:XXXX:XXXX/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::1",
                        "metric": 512,
                        "valid": 1573,
                        "source": "2409:XXXX:XXX:XXXX::2/128"
                }
        ],
        "dns-server": [
                "fe80::1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "000600160015001600170018001f003800400043005e005f006000170010fe800000000000000000000000000001"
        }
}

Ok, @LYB, if you already added option reqprefix 'auto' to the WAN6 interface (and have tried option reqprefix '56' or option reqprefix '60') in your router, then looking at the output for ifstatus wan6 you provided, I have bad news for you: your ISP doesn't delegate IPv6 prefix to the end user. Very lame ipv6 implementation from the ISP.

ipv6-prefix array is empty.

Also in Luci you don't have IPv6-PD for wan6 like this.

So, there is no ipv6 prefix delegated (IPv6-PD) that can be applied to the LAN interface.

The only option you have in this situation is to use ipv6 relay mode. So, you will be able to relay IPv6 /64 address from WAN6 to your LAN interface.

config dhcp 'wan6'
        option interface 'wan6'
        option master '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        ...
config dhcp 'lan'
        option interface 'lan'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        ...