Redmi AX6000 weird AC speed on iPad Air 2

Redmi AX6000 as dumb AP, iperf3 download test on iPad Air 2 only reaches around 150Mbps, however upload would reach 450Mbps.

This only happened with iPad Air 2, and I tried "Reset network settings" on iPad, this gave me 450Mbps+ download speed for a few iperf3 tests, then it will stay around 150Mbps again. Initially I thought it might be unstable Openwrt snapshot firmware, re-compiled several times with updates, still the same result.

Funny thing is, it is connected to AP at more than 700Mbit, 80Mhz, VHT-MCS 9, but when the speed test starts, it will drop to 250Mbits, 20Mhz or 80Mhz, VHT-MCS-3.

This ONLY HAPPENED with this old iPad Air 2, all other devices running AC protocol have no problem and no speed drop.

Is Apple doing the trick again to enforce us to buy a NEW iPad???


dir-1960 MT7621 as access point + iPad Air2
~550mbit download

Yeah weird, I will try to do a complete reset on iPad.

Ok, just did a complete reset of iPad, erased everything and started fresh.

Had good 450-600Mbit+ download speed for about 5mins while running 80Mhz, VHT-MCS 7-9, then it suddently stayed on low VHT-MCS 3-4 channel and only capable of up to 150Mbps download.

This is an iPad Air 2 updated with latest iOS 15.7.2.