Redirecting outgoing traffic to wan from lan

Hey ,
I had a problem.
I have a pi 3 that currently works for me with a vpn.
I have a usb network that provides ips and redirects them to the vpn
the pi's internal wifi network that serves as the access point that redirects it to the vpn.
A Wi-Fi network via USB that connects to the main router.
Currently the vpn works fine, but I have the output through the lan.
I would also like all the vpn traffic to go through the wifi that connects to the router. my configuration is the following:

dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option nonwildcard '1'
	option localservice '1'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	list ipset 'primevideo.com/vpnbypass'
	list ipset 'disneyplus.com/vpnbypass'
	list ipset 'play.hbomax.com/vpnbypass'
	list ipset 'netflix.com/nflxext.com/nflximg.net/nflxso.net/nflxvideo.net/vpnbypass'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ra 'server'
	option limit '150'
	option start '100'
	option dhcpv6 'server'
	option leasetime '12h'
	option ra_management '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'vpnusers'
	option interface 'vpnusers'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option start '100'
	option leasetime '12h'
	option limit '150'

network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd39:5979:add9::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option gateway '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option device 'br-lan'

config interface 'vpnusers'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '172.16.1.1'

config interface 'VPN_tun0'
	option proto 'none'
	option device 'tun0'

config interface 'wan'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option device 'eth1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'wwan'
	option proto 'dhcp'

firewall


config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config include
	option path '/etc/firewall.user'

config zone
	option name 'vpnusers'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'vpnusers'

config forwarding
	option dest 'VPN_zone'
	option src 'vpnusers'

config zone
	option name 'VPN_zone'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option masq '1'
	list network 'VPN_tun0'

config forwarding
	option dest 'VPN_zone'
	option src 'lan'

config zone
	option name 'wan'
	option input 'ACCEPT'
	option forward 'REJECT'
	option output 'ACCEPT'
	list network 'wan'

config forwarding
	option dest 'VPN_zone'
	option src 'wan'

wireless

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option band '2g'
	option htmode 'HT20'
	option country 'ES'
	option cell_density '1'
	option channel '11'
	option txpower '10'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option channel '1'
	option txpower '10'
	option country 'ES'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Pituso'
	option encryption 'psk2'
	option network 'vpnusers'
	option key '*****'

config wifi-iface 'wifinet2'
	option device 'radio2'
	option mode 'sta'
	option network 'wwan'
	option ssid 'EEUU'
	option encryption 'psk2'
	option key '*******'