Reconfiguring VLAN on OpenWrt 21.02

I had everything figured out on 19.07. I waited some time to have 21.02 pretty stable and so I jumped in and upgraded.

Not much difference except for Interface/Devices and VLAN for which I cant seem to figure out how to set it up in a way that it would be the same as before.

On 19.07 I had 4 VLANs and the setup was as such

   CPU1  |  CPU2  |   Port 1  |  Port 2  |  Port 3  |  Port 4  |  WAN  |

1 T | | | | | U | |
2 | T | | | | | U |
10 T | | U | | | | |
20 T | | | | T | | |
30 T | | | | T | | |

In parallel I had created 3 interfaces in addition to the standards one ( BR-LAN and WAN)
eth0.10 for VLAN 10
eth0.20 for VLAN 20
eth0.30 for VLAN 30

Port 3 and 4 are connected to managed switchs that manages the rest of the network. I did this becauce I wanted to segregate all network activities into 4 groups with their own set of addresses.

I looked at the tutorials for VLAN and it does not seem to address what I had. Putting all ports under the same interace is not good, unless I missed something. I cant seem to see the logic behind the type of devices, should I simply use ports, create VLAN q or what?

My router is WRT3200ACM.

Thanks,

In case you have not seen DSA wiki WIP.

Thanks for the link I saw one of the 3 links before posting. I looked at the "Converting to DSA" and tried to mimic what I had but no luck, it is not working.

Even the simplest one did not commit, VLAN 1 and 2 for all ports including WAN. My guess is that VLAN1 does not behave like before and I loose contack of the routeur while applying the settings.

Example config possibilities from a device I just use to putz around with:

example and result
root@mamba:/etc/config# cat network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fde2:1857:9a33::/48'

config device
	option name 'wan'
	option macaddr '94:10:3e:85:b5:25'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'lan1'
	option macaddr '94:10:3e:85:b5:25'

config device
	option name 'lan2'
	option macaddr '3a:4a:51:2e:90:a0'

config device
	option name 'lan3'
	option macaddr '94:10:3e:85:b5:25'

config device
	option name 'lan4'
	option macaddr '94:10:3e:85:b5:25'

config device
	option name 'brch0'
	option type 'bridge'
	list ports 'lan1'
#	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option stp '1'

config device
	option name 'brch1'
	option type 'bridge'
	list ports 'lan2'

config bridge-vlan
	option device 'brch0'
	option vlan '10'
	list ports 'lan1:u*'
#	list ports 'lan2:u'
	list ports 'lan3:u*'
	list ports 'lan4:u*'
	option alias 'lan'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'brch0.lan'

config bridge-vlan
	option device 'brch1'
	option vlan '20'
	list ports 'lan2:u'
	option alias 'iot'

config bridge-vlan
	option device 'brch1'
	option vlan '4094'
	list ports 'lan2:t*'
	option alias 'sink'
	option local '0'

config interface 'iot'
	option proto 'static'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option device 'brch1.iot'

config bridge-vlan
	option device 'brch0'
	option vlan '30'
	list ports 'lan1:t'
	option alias 'ap'

config interface 'ap'
	option proto 'static'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option device 'brch0.ap'

config interface 'windscribevpn'
	option proto 'none'
	option device 'tun0'

root@mamba:/etc/config# bridge vlan
port              vlan-id  
lan4              10 PVID Egress Untagged
lan3              10 PVID Egress Untagged
lan2              20 Egress Untagged
                  4094 PVID
lan1              10 PVID Egress Untagged
                  30
brch0             10
                  30
brch1             20
wlan1             10 PVID Egress Untagged
wlan0             10 PVID Egress Untagged
wap0              30 PVID Egress Untagged
wiot0             20 PVID Egress Untagged
wap1              30 PVID Egress Untagged
wiot1             20 PVID Egress Untagged
root@mamba:/etc/config# brctl show
bridge name	bridge id		STP enabled	interfaces
brch0		7fff.94103e85b525	yes		lan4
							            wap1
							            wlan0
							            lan3
							            wap0
							            wlan1
							            lan1
brch1		7fff.3a4a512e90a0	no		lan2
							            wiot0
							            wiot1
root@mamba:/etc/config# netifd-netinfo.sh -d
           DEVICE     UP    CARRIER    PRESENT   EXTERNAL  TYPE             
=============================================================================
            brch0      x          x          x             bridge           
         brch0_10      x          x          x             VLAN             
         brch0_30      x          x          x             VLAN             
            brch1      x          x          x             bridge           
         brch1_20      x          x          x             VLAN             
             eth0      x          x          x             Network device   
             lan1      x                     x             Network device   
             lan2      x                     x             Network device   
             lan3      x          x          x             Network device   
             lan4      x          x          x             Network device   
               lo      x          x          x             Network device   
              wan      x          x          x             Network device   
             wap0      x          x          x          x  Network device   
             wap1      x          x          x          x  Network device   
            wiot0      x          x          x          x  Network device   
            wiot1      x          x          x          x  Network device   
            wlan0      x          x          x          x  Network device   
            wlan1      x          x          x          x  Network device   

be sure you are on RC4.

Thanks, I looked at it and from what I could understand, it looks a bit like my setup (have 1 VLAN for IOT). On the other hand, I was a bit lost in the list of interfaces, devices, bridges that are defined. I am not sure I fully understand the need for so many.

I will at it a bit more during the weekend.