Recommendation for modem router

I have had a recommendation to buy a modem router to install lede.. and some guys has told me to buy tp-link td-w8970 v1 or v1.2. Then I have bought it on ebay. When it is arrived I have discovered that the oem firmware does not accept (with webgui) lede image because it need only signed firmware. Then I read on the device's page to install the firmware by serial. Then I have bought the solder, the connectors and the usb to ttl interface. When everything is arrived I must learn how to solder because I had never done it. Ok I soldered the connector on the pc I run minicom and I see the boot log... now I discover that the (fucking) uboot prompt don't come up... I mean I press the "t" key early on the boot... then I have tried other key.. I checked the loop test on the ttl usb cable... and many other fucking stuff.. uboot dont want give me the prompt.
Then I will put this "very well" supported modem router on the trash and I will buy an other one.
Please anyone could advice me a modem router with the follogin feature (?):

  • have adsl modem
  • must support openvpn for just one user.. I have an adsl with 20mbit of bandwidth
  • lede must be easy to install

not needed or supported wifi... just it must be work!
Thank u

1 Like

To narrow down your search a bit:[Modem*~]=dsl

Enter your filter criteria in the white fields in the header.

Maybe the forum search will have also some useful results for you.

You do have to consider that only lantiq based ADSL/ VDSL modems currently have full modem support - and all of them will require a roughly similar procedure for the initial flashing.

There are basically two options which might be a little easier.

  • you can sometimes find the BT Home Hub 5a preflashed with LEDE, these are around ~3 times more expensive that the vanilla variant (which would need similar efforts for the initial flash as your td-w8970)
  • apparently there is a 'simpler' approach for the Arcadyan VGV7510KW22 (o2 Box 6431), by abusing the the vendor's brnboot based recovery
    Installing LEDE/u-boot via brnboot web interface (without rs232)

Hardware wise, the BT Home Hub 5a is a much better option - if you get one preflashed with LEDE, you can just sysupgrade straight ahead.

For a concrete recommendation, you need to specify this further. Practically all chipsets can do both VDSL, but most are limited to either Annex A or Annex B ADSL2+. (For example, the above-recommended Home Hub 5a can only do Annex A.)

Also, let's keep the forum language family friendly, shall we? :slight_smile:

hi again,
what do u think about dm200 ... I need of annex A

1.) I thing you should not give up
because you can only bay an equal Hardware*
Did you have wire VCC ? (should not)
Are you 100% shure that you have correct wired (are you shure that the Tx is not on GND)

2.) can put the full log of your trys on pastebin it can be interessting for other people.

* Is this true (now) that no support for other DSL devices exist without lantiq/xway and lantig/xrx200, like broadcom ?
Why do no binary firmware works on broadcom like Lantiq Vectoring firmwares. ?

Because lantiq just needs a binary firmware (which is independent of the running kernel version), the others also require a binary driver (which only works with the ancient vendor kernel).

is it not a GPL viollation ?

@Plonk34 I am pretty sure I have done all things I can.

  • I have tried different software to connect: minicom, screen and cu
  • I have changed the wire, connected the gnd to the metal on the router, switched tx with rx. (anyway if I disconnect the GND I don't see any kind of output logs..If I connect the GND to the metal I see the output like if it is connected to the GND pin on serial)
  • I have tested the cable connecting tx to the rx and it works
  • I have tried to press T,t - ESC - ENTER - and tpl and many other random keys. (on the boot I read "press any key to stop autoboot" or something like that)
  • I have tried to hack the SSID like explained on the device page, look at SSID config injection
  • I have tried the web gui but my oem fimrware want only signed firmware
  • I have tried different speed on minicom from 115200 to 9600 and tryied enabling disabling flow control
  • here a guy says there are about 40 forks of u-boot... (sigh!) Also he says to try a NULL modem cable...(sigh sigh)
  • here the usb to ttl cable I have bought and used
  • during the boot, there is a message says something like "press enter to activate this console". I press enter exactly in that while but nothing succeed.

IMHO it's much more cheap to buy an other one.

Anyway, I will try to:

  • hack the configuration like explained in the above page linked
  • change the cable

finally I will buy an other one, with prime on amazon I will get it in few days.

As Plonk34 said I wouldn't give up on your current router yet. It really sounds like a problem with your serial connection. I tried two different USB to serial adapters and had problems with both. Your picture looks like a PL2303 based one (run lsusb to find out) and I had the exact same problem you described, but on a TP-Link Archer VR200v.
In the end I successfully used a Raspberry Pi 3 to establish a serial connection. If you have a Rpi at home use that, there are plenty of HowTos on how to do that.

But of course, we have no idea what things do you try, and what do you have checked.

I wondering because inside the wiki of this Router is no note to do not using the serial VCC connector.
(I have no idea if is right or wrong)
I know from Arcadyan devices with same chipset that should not be used.
I have do it and the result was: after a short time i grill my PL2303HX (the version with an additional 5V connector, but without case).
My theory was you have do the same, but you do not destroy the PL2303 complett, but only the Tx-port.

What happen on the end when the OEM-firmware was succefull started ?
Have you any reaction for from the console ?

A full log of your serial connection will be interrestesting, because for equaling with the exist logs in the wiki and the web.
For example to see what uboot version was used.
And it can be interrestesting for people in Future with the same problem.

Which Version of OEM Firmware is installed ?

Hi again,
well I have tried with BeagleBone black because I haven't raspberry. I have exactly the same result I have with the USB to ttl converter. BBB has its own serial then I have connected it to the router serial. And does not work. With the bbb somtimes I have some strange output.. I mean there are some lines more at the end of line output... I think it's a problem with the carriage return character.
In few minutes I will give u the output log of the OEM firmware. Thank so much for your help.

Please keep this topic for hardware recommendations.
If you have questions on how to troubleshoot / flash TD-W8970, please open a new topic (or rename this topic in order to reflect the issues being discussed here).

Hi, I have pasted the boot log on pastebin, but please answer in the proper thread.

I'm using a chinese router called ZBT WG-3526. It's working very well until now.

This device does not have a modem.

it' true... sorry. I read modern router. :slight_smile:

As you have a modem router which is supposedly supported but you have had issues installing LEDE , i personally would not give up "YET". I have a TPLINK device which is very similar and gave me hell when trying to install OPENWRT or DDWRT.(Would not accept Non Signed Software image) I found a guide to start in recovery mode and finally managed everything with great success. Have you tried recovery mode to force install? Here is a guide for DDWRT install however i followed it (Still had trouble getting into revery - not straight forward and hard to tell if you are in recovery mode ) I had to use a program Tftpd64-4.60 to setup a tftp server and flash the device. When in recovery mode the device looks for a TFTP server with update firmware. You must setup your TFTP server with a static IP and the firmware you wish to flash . The Device will boot into recovery mode (not as easy as mentioned above) but when it does It will check for a TFTP server and download the firmware. Hopefully it works for you, i almost gave up , actually i did give up after some days, then tried again weeks later and then again. But frustration and persistence worked. Anyway here is the link and hopefully leads you in the right track. (EDITED)

As to the question of Modem with Open VPN support and LEDE, i would have stuck with the TD-W8970 hope this covers the relatively of my post for forum police

Did you check if you need a pull up resistor on the TX