Received packet on lan2 with own address as source address

I have a massive problem going from
OpenWrt SNAPSHOT, r23808-67dacdd652 to OpenWrt SNAPSHOT, r24111-66f6c20e45
With the same config my syslog is flooded by:

[Tue Oct 10 13:10:13 2023] br-lan: received packet on lan2 with own address as source address (addr:2c:3a:fd:ef:1b:5e, vlan:0)
[Tue Oct 10 13:10:13 2023] br-lan: received packet on lan2 with own address as source address (addr:2c:3a:fd:ef:1b:5e, vlan:0)
[Tue Oct 10 13:10:13 2023] br-lan: received packet on lan2 with own address as source address (addr:2c:3a:fd:ef:1b:5e, vlan:0)
[Tue Oct 10 13:10:13 2023] br-lan: received packet on lan2 with own address as source address (addr:2c:3a:fd:ef:1b:5e, vlan:0)
[Tue Oct 10 13:10:13 2023] br-lan: received packet on lan2 with own address as source address (addr:2c:3a:fd:ef:1b:5e, vlan:0)

My config:
(It is connected to another main openwrt router, so it's been used as a secondary router)

root@fb7530:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfa:847d:6e23::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'j'
	option tone 'b'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

Is this a separate interface?

I think you accidentally added the "master interface" connecting the CPU too.

  • What is the make/model of your device?
  • Is there a reason you're not running a release version?
1 Like