Realtek RTL8125 2.5gbe worked 22.03 not working 23.05

Hi everyone, a few days a go I upgraded from 22.03 stable to 23.05 stable on my x86 box and since the upgrade my 4 port Realtek RTL8125 pcie card will only run at 1gbe speed, it worked fine at 2.5gbe speed on 22.03.

I've googled but haven't found a solution, I did find drivers here: https://github.com/csrutil/realtek-r8125-openwrt/releases but I can't seem to find the correct firmware anywhere. Openwrt is using R8169 driver and firmware by default since the upgrade which is where the issue seems to be (using incorrect driver and firmware).

Does anyone have any ideas or can point me somewhere to find more information?

Thanks.

Anything in dmesg? What does ethtool report concerning capabilities?

1 Like

Hi, thanks for getting back to me. eathtool says 2500 is supported but is not using it:

root@router:~# ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
                                2500baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

dmesg I'm not too sure what I should look for in here? there's a lot of messages for about links up and down, is there something I should have a look for specifically?

Any errors linked to the Realtek NIC e.g.

I do see ethtool saying the 'link partner' on the other end can do no more then 1 Gbps? That's something to investigate I'd say.

netifd in 23.05 probably needs this as well:

1 Like

@robimarko You think that might fix it? @Trozmagon Can you test a main snapshot image?

Yes, as 2.5G was not advertised before this commit.

1 Like

Thanks guys, this looks like it could be it. I'll try the snapshot tonight and get back with the results :slight_smile:

Thanks for your help guys, I've done a full reinstall and setup from scratch and it's working without issues, maybe some sort of configuration issue caused by doing an upgrade.

Appreciate the help :slight_smile:

So, on 23.05?