Realtek based OpenWrt SMBv1/2/3 Server won't work with Hisillicon SMBv1.5 based Clients (which do work with W10 Server)

I am not familiar in any detail with OpenWRT but yes quite familiar with Android TV and Android based media players but that same client works perfectly with Windows10 being the reference.

All advanced media players today include both a SMB/CIFS Server and Client. Using a NAS is very popular these days as media files keep growing constantly. Running media players as a NAS works very well these days with gigabit wire-rate throughput.
The top of the line media players today are either based on chipsets (SOC) of Hisillicon (e.g. Dinobot, Egreat and Himedia) or Realtek RTD1295/1296 (Zidoo, Dune, Eweat, Zappiti). The Realtek SDK standard comes with OpenWRT next to Android for background communication which is an excellent combination. The Hisillicon SOC based players include a SMB Client restricted to SMBv1.5 support on all Android OS versions thus far implemented (5, 7 and 8).

The problem is that using OpenWRT SMB Server won't interwork with Hisillicon SMBv1.5 based SMB clients. At least I don't get it to work. The client will find the OpenWRT Server, can connect to it and will see the correct mounts on it. So far all well but next only Root (..) will show up on these mounts, no directories/files shown. The exception is the Android System mount which is accesible.
The same clients will connect to a microsoft windows W10 SMB Server after enabling SMBv1 just fine. So OpenWRT must be doing something different somewhere than W10? I hope a setting can fix this?

Help will be greatly appreciated not just by me but by the media player community as a whole as many are running into this problem,

OpenWrt Chaos Calmer 15.05.1

netbios name = |NAME|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
browseable = yes
deadtime = 30
encrypt passwords = yes
enable core files = no
guest account = nobody
guest ok = yes
invalid users = root
local master = yes
load printers = no
map to guest = Bad User
min receivefile size = 16384
obey pam restrictions = yes
os level = |OSLEVEL|
passdb backend = smbpasswd
preferred master = yes
printable = no
inherit owner = yes
create mask = 0777
directory mask = 0777
force create mode = 0777
force directory mode = 0777
security = user
smb encrypt = disabled
smb passwd file = /etc/samba/smbpasswd
syslog = 2
use sendfile = yes
max xmit = 65535
max connections = 8
dns proxy = no
writeable = yes
vfs objects = posixacl
aio read size = 0
aio write size = 0

By the way the reverse does not work either: Using A7 on Hisillicon supports SMB v1/2/3 Server but won't talk to Realtek based SMBv1/2 clients. But this is not an OpenWRT problem
The crazy thing all Servers/Clients from both Hisillicon and Realtek do talk correctly with Windows10.

Realtek SoCs are not supported by OpenWrt. We have no idea what's in their codebase.

Thanks for the response. Dead end street for me.

Is it possible to test or known if supported platforms do inter-work correctly with HiSillicon SMB clients running on Android media players (Himedia/Egreat/Dune/Dinobot) by anybody here?

maybe something like this will help

just add this line to the global section

ntlm auth = yes

It should look like this now

netbios name = |NAME|
interfaces = |INTERFACES|
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
ntlm auth = yes

1 Like

Tried the nltm auth=yes parameter, but unfortunately that one does not solve.
Still works with W10 and not with Hisillicon.
I think the authentication is not the problem anyway as the correct mounts do show up.
They just remain empty with exception of the Android System mount.

Thanks a lot though for thinking along.