Read Only Filsystem Blocking Package Updates

So I installed OpenWRT on my TP-Link Archer C6 v3.2 & it worked great. Installed packeges & such without issues. But then I found that some package updates are available. I tried updating them using LuCI 1st; then using ssh. Both of them said read only filesystem (error 255). I tried flashing the sysupgrade snapshot. But that didn't fix it. Did a reset. Didn't do anything either. So, anyway of fixing it? Or maybe how to reinstall OpenWRT??

What are the package names can you tell?

If they are base-files or something related to internal packages don't try to upgrade them this may cause os issues

Here is a similar issue I think:

And um I think error255 is related to opkg update issues if not paste your error logs here

1 Like

I've had both issues. 1st I had that read only issue when trying to update base-files & luci-base. Then after I did sysupgrade snapshot to try & fix that; it showed that opkg error (255). So there ya have it. And I tried reinstalling from the base snapshot (the one I used on my first flash from stock firmware). That seems to fail signature check. And it shows caution that might brick the device. So didn't go through with it. Anyways, so I just should leave the base packages untouched then?

Yes you shouldn't try messing with the base files..leave them as it is....

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.