RE6500 w/ 24.10: wired LAN port 1 only functions in failsafe mode

I'm trying to set up a Linksys RE6500 as an ethernet-to-wifi bridge (not a repeater), using 24.10.latest (as of two days ago), and I'm having a really weird problem: When booted normally, wired LAN port 1 is nonfunctional. I plug in a cable and nothing happens, the link light doesn't turn on and the computer at the other end thinks the cable is still unplugged. At the same time, it does associate to its configured upstream AP, so I think it's not completely dead. EDIT: It is otherwise fully operational; wired LAN ports 2, 3, and 4 work correctly and the device acts as a bridge between them, and from them to the wifi network.

When booted into failsafe mode, wired port 1 works fine (and is in fact the only one that can be used to ssh into the device).

What might be wrong? Any suggestions for troubleshooting?

Note: This device's onboard storage is too small for the stock 24.10 image. I had to make a custom build with LuCI and a bunch of other packages removed. Having done that, I was able to flash the image, boot it into failsafe mode, connect to it on a wired LAN port, and configure it. Configuration details below.

/etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd68:6f01:a8be::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	option stp '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.0.0.2'
	option netmask '255.255.255.0'
	option ip6assign '60'
/etc/config/wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option channel 'auto'
	option htmode 'VHT80'
	option country 'US'
	option cell_density '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'sta'
	option ssid '<redacted>'
	option encryption 'sae'
	option key '<redacted>'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option wds '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '2g'
	option channel 'auto'
	option htmode 'HT20'
	option country 'US'
	option cell_density '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid '<redacted>'
	option encryption 'sae'
	option key '<redacted>'
	option ieee80211w '1'
	option wpa_disable_eapol_key_retries '1'
	option wds '1'
opkg list
base-files - 1655~6df0e3d02a
busybox - 1.36.1-r2
ca-bundle - 20240203-r1
dropbear - 2024.86-r1
fstools - 2024.07.14~408c2cc4-r1
fwtool - 2019.11.12~8f7fe925-r1
getrandom - 2024.04.26~85f10530-r1
hostapd-common - 2024.09.15~5ace39b0-r2
iw - 6.9-r1
iwinfo - 2024.10.20~b94f066e-r1
jansson4 - 2.14-r3
jshn - 2024.03.29~eb9bcb64-r1
jsonfilter - 2024.01.23~594cfa86-r1
kernel - 6.6.73~3abe85def815b59c6c75ac1f92135cb6-r1
kmod-cfg80211 - 6.6.73.6.12.6-r1
kmod-crypto-aead - 6.6.73-r1
kmod-crypto-authenc - 6.6.73-r1
kmod-crypto-ccm - 6.6.73-r1
kmod-crypto-cmac - 6.6.73-r1
kmod-crypto-crc32c - 6.6.73-r1
kmod-crypto-ctr - 6.6.73-r1
kmod-crypto-des - 6.6.73-r1
kmod-crypto-gcm - 6.6.73-r1
kmod-crypto-geniv - 6.6.73-r1
kmod-crypto-gf128 - 6.6.73-r1
kmod-crypto-ghash - 6.6.73-r1
kmod-crypto-hash - 6.6.73-r1
kmod-crypto-hmac - 6.6.73-r1
kmod-crypto-hw-eip93 - 6.6.73-r1
kmod-crypto-manager - 6.6.73-r1
kmod-crypto-md5 - 6.6.73-r1
kmod-crypto-null - 6.6.73-r1
kmod-crypto-rng - 6.6.73-r1
kmod-crypto-seqiv - 6.6.73-r1
kmod-crypto-sha1 - 6.6.73-r1
kmod-crypto-sha256 - 6.6.73-r1
kmod-crypto-sha3 - 6.6.73-r1
kmod-crypto-sha512 - 6.6.73-r1
kmod-gpio-button-hotplug - 6.6.73-r5
kmod-leds-gpio - 6.6.73-r1
kmod-lib-crc32c - 6.6.73-r1
kmod-mac80211 - 6.6.73.6.12.6-r1
kmod-mt76-core - 6.6.73.2025.01.14~8e4f72b6-r1
kmod-mt76x02-common - 6.6.73.2025.01.14~8e4f72b6-r1
kmod-mt76x2 - 6.6.73.2025.01.14~8e4f72b6-r1
kmod-mt76x2-common - 6.6.73.2025.01.14~8e4f72b6-r1
kmod-nf-conntrack - 6.6.73-r1
kmod-nf-conntrack6 - 6.6.73-r1
kmod-nf-flow - 6.6.73-r1
kmod-nf-log - 6.6.73-r1
kmod-nf-log6 - 6.6.73-r1
kmod-nf-nat - 6.6.73-r1
kmod-nf-reject - 6.6.73-r1
kmod-nf-reject6 - 6.6.73-r1
kmod-nfnetlink - 6.6.73-r1
kmod-nft-core - 6.6.73-r1
kmod-nft-nat - 6.6.73-r1
kmod-nft-offload - 6.6.73-r1
libblobmsg-json20240329 - 2024.03.29~eb9bcb64-r1
libc - 1.2.5-r4
libgcc1 - 13.3.0-r4
libiwinfo-data - 2024.10.20~b94f066e-r1
libiwinfo20230701 - 2024.10.20~b94f066e-r1
libjson-c5 - 0.18-r1
libjson-script20240329 - 2024.03.29~eb9bcb64-r1
libmbedtls21 - 3.6.2-r1
libmnl0 - 1.0.5-r1
libnftnl11 - 1.2.8-r1
libnl-tiny1 - 2023.12.05~965c4bf4-r1
libpthread - 1.2.5-r4
libubox20240329 - 2024.03.29~eb9bcb64-r1
libubus20250102 - 2025.01.02~afa57cce-r1
libuci20250120 - 2025.01.20~16ff0bad-r1
libuclient20201210 - 2024.10.22~88ae8f20-r1
libucode20230711 - 2025.02.10~a8a11aea-r1
libudebug - 2023.12.06~6d3f51f9
libustream-mbedtls20201210 - 2024.07.28~99bd3d2b-r1
logd - 2024.04.26~85f10530-r1
mtd - 26
netifd - 2024.12.17~ea01ed41-r1
nftables-json - 1.1.1-r1
openwrt-keyring - 2024.11.01~fbae29d7-r2
opkg - 2024.10.16~38eccbb1-r1
procd - 2024.12.22~42d39376-r1
procd-seccomp - 2024.12.22~42d39376-r1
procd-ujail - 2024.12.22~42d39376-r1
ubi-utils - 2.2.1-r1
ubox - 2024.04.26~85f10530-r1
ubus - 2025.01.02~afa57cce-r1
ubusd - 2025.01.02~afa57cce-r1
uci - 2025.01.20~16ff0bad-r1
uclient-fetch - 2024.10.22~88ae8f20-r1
ucode - 2025.02.10~a8a11aea-r1
ucode-mod-fs - 2025.02.10~a8a11aea-r1
ucode-mod-nl80211 - 2025.02.10~a8a11aea-r1
ucode-mod-rtnl - 2025.02.10~a8a11aea-r1
ucode-mod-ubus - 2025.02.10~a8a11aea-r1
ucode-mod-uci - 2025.02.10~a8a11aea-r1
ucode-mod-uloop - 2025.02.10~a8a11aea-r1
urandom-seed - 3
urngd - 2023.11.01~44365eb1-r1
usign - 2020.05.23~f1f65026-r1
wifi-scripts - 1.0-r1
wireless-regdb - 2025.02.20-r1
wpad-basic-mbedtls - 2024.09.15~5ace39b0-r2

All other config files are unmodified from their state after running firstboot, mount_root and passwd from failsafe mode (in that order, with a reboot after the firstboot).

Remove STP:

Based on the below, I'm guessing this is not the main router, is that correct?

Is the main router on the same subnet? And is 10.0.0.2 available on your network?

You know that stp delays interfaces coming up. Might mot be the best idea to intentionally loop 2 wifis on a general purpose bridge.

No effect. There is still no link light on either end of the cable and my laptop still thinks the cable is unplugged.

(Why would layer-2 options have any effect on a PHY issue?)

Yes. The overall topology of the LAN is like

WAN --- main router *** *** *** RE6500 --- wired
                   \*** wifi          \--- clients
                   \--- and wired
                   \*** clients

where --- is a wired (Ethernet) connection and *** a radio connection. (Crucially, the RE6500 is not acting as a wifi repeater, only a wifi-to-ethernet bridge. It's also not acting as a DHCP server, that's the main router's responsibility.)

The main router is a WRT1900ACv1 also running 24.10. It's at 10.0.0.1, its DHCPv4 server is using the 10.0.0.100 -- 10.0.0.250 range, and nothing else is statically assigned to 10.0.0.2. All devices are configured with a /24 subnet mask.

Immediately after posting the above it occurred to me to try the other Ethernet ports on the RE6500. There are four, numbered 1 through 4, left to right; there is no special "wan" port marked on the case or anything else to distinguish them.

In failsafe mode, all four ports turn on the link light when I plug in an Ethernet cable with a computer attached to the other end, but the device only responds to ARP queries, pings, or SSH connections if the cable is plugged in to port 1.

In normal mode, port 1 does not turn on its link light when I connect a cable, but the other three do, and the device is actually fully functional as desired (that is, as an Ethernet-to-wifi bridge) for computers connected to those three ports.

So this suggests that there is a difference between port 1 and ports 2/3/4 internally, even though the case labeling does not reflect that, and port 1 isn't configured correctly (in normal mode). Any advice on how to fix that? The only thing in /etc that seems relevant to port configuration is this chunk of /etc/config/network...

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

Below is the output of ip addr list on the RE6500 in both modes.

ip addr list, failsafe boot, port 1 connected
1: lo: <LOOPBACK> mtu 65536 qdisc noop state DOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST> mtu 1504 qdisc noop state DOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
3: lan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global lan1
       valid_lft forever preferred_lft forever
    inet6 fe80::1691:82ff:fe19:1875/64 scope link 
       valid_lft forever preferred_lft forever
4: lan2@eth0: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <BROADCAST,MULTICAST,M-DOWN> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
ip addr list, normal boot, port 2 connected
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::1691:82ff:fe19:1875/64 scope link 
       valid_lft forever preferred_lft forever
3: lan1: <BROADCAST,MULTICAST> mtu 1500 qdisc mq master br-lan state DOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 14:91:82:19:18:75 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd68:6f01:a8be::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::1691:82ff:fe19:1875/64 scope link 
       valid_lft forever preferred_lft forever
8: phy0-sta0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 14:91:82:19:18:76 brd ff:ff:ff:ff:ff:ff
9: phy1-sta0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 14:91:82:19:18:78 brd ff:ff:ff:ff:ff:ff

I just had a look at the .dts at here and there is indeed a difference between lan1 and the other ports: lan1 is, by default, configured as wan and, in order to allow better lan-wan throughput, configured to use a different GMAC. The relevant thread can be found here:

That said, it should still work as intended, though traffic between lan1 and the other ports is probably going through the CPU (I'm not sure on this, I didn't follow the development of the aforementioned patch).

I maintain a few mt7621 devices where I did a similar reconfiguration, but they are all still on 23.05.

Can you show the output of logread -f when you disconnect and connect a cable to lan1 (obviously, with the other end connected to a working device)?

1 Like

Thanks for confirming my suspicions.

In order to answer your question about log messages I'm going to have to find a second device I can plug into the RE6500 while it's on the bench, which might take a couple of days. (The things it's normally hooked to are difficult to move around.)

@andyboeh First I booted the device into failsafe mode, and ssh-ed in on a cable connected to jack #1.

Failsafe mode dmesg | grep -E 'eth|lan'; one cable already connected to jack #1
[    2.811682] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    2.831722] mtk_soc_eth 1e100000.ethernet eth1: mediatek frame engine at 0xbe100000, irq 19
[    3.027675] mt7530-mdio mdio-bus:1f lan2 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7530 PHY] (irq=21)
[    3.056749] mt7530-mdio mdio-bus:1f lan3 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7530 PHY] (irq=22)
[    3.089335] mt7530-mdio mdio-bus:1f lan4 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7530 PHY] (irq=23)
[    3.112605] mtk_soc_eth 1e100000.ethernet eth0: entered promiscuous mode
[    6.518591] mtk_soc_eth 1e100000.ethernet lan1: renamed from eth1
[    8.438476] mtk_soc_eth 1e100000.ethernet lan1: PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=POLL)
[    8.467159] mtk_soc_eth 1e100000.ethernet lan1: configuring for phy/rgmii link mode
[   20.936002] mtk_soc_eth 1e100000.ethernet lan1: Link is Up - 1Gbps/Full - flow control rx/tx

Then I connected a second device to jack #4. Link lights turned on on both ends of the second cable, but no new messages appeared in dmesg output.

Shut down, disconnected both cables, booted back up into normal mode, connected the laptop I'm using for diagnostics to jack #4. Link lights turned on on both ends, RE6500 is pingable and ssh-able and is forwarding packets to the main router.

Normal mode logread | grep -E 'eth|lan'; one cable already connected to jack #4; prefixes edited down for readability
11m55s kernel: mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
11m55s kernel: mtk_soc_eth 1e100000.ethernet eth1: mediatek frame engine at 0xbe100000, irq 19
11m55s kernel: mt7530-mdio mdio-bus:1f lan2 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7530 PHY] (irq=21)
11m55s kernel: mt7530-mdio mdio-bus:1f lan3 (uninitialized): PHY [mt7530-0:02] driver [MediaTek MT7530 PHY] (irq=22)
11m55s kernel: mt7530-mdio mdio-bus:1f lan4 (uninitialized): PHY [mt7530-0:03] driver [MediaTek MT7530 PHY] (irq=23)
11m55s kernel: mtk_soc_eth 1e100000.ethernet eth0: entered promiscuous mode
11m55s kernel: mtk_soc_eth 1e100000.ethernet lan1: renamed from eth1
11m55s kernel: mtk_soc_eth 1e100000.ethernet lan1: PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=POLL)
11m55s kernel: mtk_soc_eth 1e100000.ethernet lan1: configuring for phy/rgmii link mode
11m57s user: Added device handler type: macvlan
11m57s user: Added device handler type: veth
12m00s kernel: mtk_soc_eth 1e100000.ethernet lan1: PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=POLL)
12m00s kernel: br-lan: port 1(lan1) entered blocking state
12m00s kernel: br-lan: port 1(lan1) entered disabled state
12m00s kernel: mtk_soc_eth 1e100000.ethernet lan1: entered allmulticast mode
12m00s kernel: mtk_soc_eth 1e100000.ethernet lan1: entered promiscuous mode
12m00s netifd: Interface 'lan' is enabled
12m00s netifd: Interface 'lan' is setting up now
12m00s netifd: Interface 'lan' is now up
12m00s kernel: mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
12m00s kernel: mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
12m06s kernel: mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
12m06s kernel: br-lan: port 2(lan2) entered blocking state
12m06s kernel: br-lan: port 2(lan2) entered disabled state
12m06s kernel: mt7530-mdio mdio-bus:1f lan2: entered allmulticast mode
12m06s kernel: mtk_soc_eth 1e100000.ethernet eth0: entered allmulticast mode
12m06s kernel: mt7530-mdio mdio-bus:1f lan2: entered promiscuous mode
12m06s kernel: mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
12m06s kernel: br-lan: port 3(lan3) entered blocking state
12m06s kernel: br-lan: port 3(lan3) entered disabled state
12m06s kernel: mt7530-mdio mdio-bus:1f lan3: entered allmulticast mode
12m06s kernel: mt7530-mdio mdio-bus:1f lan3: entered promiscuous mode
12m06s kernel: mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
12m06s kernel: br-lan: port 4(lan4) entered blocking state
12m06s kernel: br-lan: port 4(lan4) entered disabled state
12m06s kernel: mt7530-mdio mdio-bus:1f lan4: entered allmulticast mode
12m06s kernel: mt7530-mdio mdio-bus:1f lan4: entered promiscuous mode
12m06s netifd: Network device 'eth0' link is up
12m09s kernel: mt7530-mdio mdio-bus:1f lan4: Link is Up - 1Gbps/Full - flow control rx/tx
12m09s kernel: br-lan: port 4(lan4) entered blocking state
12m09s kernel: br-lan: port 4(lan4) entered listening state
12m09s netifd: Network device 'lan4' link is up
12m16s kernel: br-lan: port 5(phy0-sta0) entered blocking state
12m16s kernel: br-lan: port 5(phy0-sta0) entered disabled state
12m16s kernel: br-lan: port 5(phy0-sta0) entered disabled state
12m16s kernel: br-lan: port 5(phy0-sta0) entered blocking state
12m16s kernel: br-lan: port 5(phy0-sta0) entered disabled state
12m17s kernel: br-lan: port 4(lan4) entered learning state
12m19s kernel: br-lan: port 6(phy1-sta0) entered blocking state
12m19s kernel: br-lan: port 6(phy1-sta0) entered disabled state
12m19s kernel: br-lan: port 6(phy1-sta0) entered disabled state
12m19s kernel: br-lan: port 6(phy1-sta0) entered blocking state
12m19s kernel: br-lan: port 6(phy1-sta0) entered disabled state
12m23s kernel: br-lan: port 5(phy0-sta0) entered blocking state
12m23s kernel: br-lan: port 5(phy0-sta0) entered listening state
12m24s kernel: br-lan: port 6(phy1-sta0) entered blocking state
12m24s kernel: br-lan: port 6(phy1-sta0) entered listening state
12m26s kernel: br-lan: port 4(lan4) entered forwarding state
12m26s kernel: br-lan: topology change detected, propagating
12m26s netifd: bridge 'br-lan' link is up
12m26s netifd: Interface 'lan' has link connectivity
12m31s kernel: br-lan: port 5(phy0-sta0) entered learning state
12m32s kernel: br-lan: port 6(phy1-sta0) entered learning state
12m39s kernel: br-lan: port 5(phy0-sta0) received tcn bpdu
12m39s kernel: br-lan: topology change detected, propagating
12m40s kernel: br-lan: port 5(phy0-sta0) entered forwarding state
12m40s kernel: br-lan: topology change detected, propagating
12m40s kernel: br-lan: port 6(phy1-sta0) entered forwarding state
12m40s kernel: br-lan: topology change detected, propagating

Upon connecting a second cable to port 2 (and then disconnecting it again) link lights turn on and back off as expected, and I see these additional log messages:

Normal mode logread -f while connecting and disconnecting a second device to port 2; prefixes edited down for readability
30m33s kernel: mt7530-mdio mdio-bus:1f lan2: Link is Up - 1Gbps/Full - flow control off
30m33s kernel: br-lan: port 2(lan2) entered blocking state
30m33s kernel: br-lan: port 2(lan2) entered listening state
30m33s netifd: Network device 'lan2' link is up
30m39s kernel: mt7530-mdio mdio-bus:1f lan2: Link is Down
30m39s kernel: br-lan: port 2(lan2) entered disabled state
30m39s netifd: Network device 'lan2' link is down

However, upon connecting the same second device to port 1, nothing happens. The link lights do not turn on and there are no additional log messages.

You cannot set IP on a bridge menmber. Please show entire config/network.

It is very suspicious if nothing happens, there should be at least the link up / link down messages.
I can try to reproduce this on the weekend on a ZyXEL WSM20. That device should have a similar SoC and the same Ethernet config. I have a WSM20 with your config in production use, but that's still on 23.05.

1 Like

You cannit join bridge or bond unless you wipe l3 addresses completely.

Could you point out to me where you spotted this?

Failsafe has 192.168 on lan1 while normal boot has 10.x on br-lan. If 192 on lan1 is in conf files configs race to no good.

Yes, that's the behavior of failsafe mode - it defaults to 192.168.1.1 and ignores the configuration files.

AFAICT, OP posted the full network config in the first post.

Yes, the full /etc/config/network used in normal mode is posted at the beginning of the thread. I have since added a static default route and DNS server but that shouldn't have any bearing on the issue at hand.

192.168.1.x addresses are only in use in failsafe mode. I have been trying to label all the logs and config file excerpts clearly, please let me know if anything is still confusing.

Yeah, with these symptoms I'd normally think there was a hardware failure, but the port does work in failsafe mode...

@andyboeh Did you have any luck reproducing the problem with your WSM20?