RE6500 Rapidly Blinking White Light After TFTP transfers file

I am following the steps here: https://openwrt.org/toh/linksys/re6500

I am using tftpd64 on windows 10, I have manually changed the TCP/IPv4 properties to 192.168.1.100 for the computer, a subnet mask of 255.255.255.0 and the gateway as 192.168.1.1
The initramfs bin file (renamed as um_factory_fw.bin) even appears to transfer to the RE6500 just fine. However, after it gets the bin file, the white light goes solid, and then starts to blink really fast. This is not the typical slow blink, this is quite rapid. After a restart, everything is fine again, as if nothing happened (no openwrt flashing)
How can I fix this? The firmware of the RE6500 is at 1.0.011.
Thanks!

OpenWRT is only loaded into memory after this initial procedure. Before rebooting you have to enter the OpenWRT interface at 192.168.1.1 and then flash the sysupgrade file. Here are detailed directions I have written for myself.

The official firmware does checks on the image and rejects non-linksys images so it can't be used to flash OpenWrt. To install OpenWrt follow these steps:

  1. Download initramfs-kernel.bin and sysupgrade.bin for RE6500.

  2. Set up a TFTP server (Tftpd64 on Windows). Have it host the initramfs file but rename it to um_factory_fw.bin

  3. There won't be time to do a DHCP exchange so configure the TFTP server (the PC) to have a 192.168.1.100 address on a 255.255.255.0 subnet. Choose the folder where the files are stored for the "Current Directory" in Tftpd64. Choose 192.168.1.100 for "Server interfaces".

  4. Connect with an ethernet cable from PC to RE6500 and power the RE6500 on. Immediately after receiving power the RE6500 will make a TFTP request and boot the um_factory_fw.bin into memory. This will effectively boot a live version of OpenWrt. You will know that you did it right if the extender has both the white and orange LEDs on after it is done booting, resulting in a milky white led with a distinct orange hue. The original firmware never lights them at the same time. The individual LEDs can also be observed through the front grille.

5.Use OpenWrt's web interface at 192.168.1.1 and login with root/admin. From here you can flash the sysupgrade image.

  1. Don't forget to shut down the TFTP server or you'll just load the initramfs image again!

  2. After rebooting the extender you should now have OpenWrt running from the device.

Thanks for your reply!
Yes, I followed those steps, but after the RE6500 pulls the um_factory_fw.bin file, it does not boot properly. I believe that I have configured everything correctly, because the RE6500 does pull the firmware, I can see in Tftpd64 that the router (192.168.1.1) pulls the file "um_factory_fw.bin", but only after it pulls it I have issues. Instead of the white light on the router turning white and orange at the same time, the white light instead turns solid for a second or two, and then starts to flash very rapidly. Multiple times a second. It stays this way forever (until I unplug the router). Every time I have tried this, this fast blinking is the result.
In your answer, you mentioned keeping both the .bin files in the tftpd64 directory, does the router pull the sysupgrade file as well as the initramfs-kernel file? Should I also rename the sysupgrade file to sysupgrade.bin? I'm guessing not, but I am really confused as to why mine doesn't like the initramfs-kernel file (renamed to um_factory_fw.bin, or course).
My firmware is on the latest version, which is 1.0.012.001, maybe it has some other new protections installed to reject other firmware? Should (or can, rather) I try downgrading to the still downloadable 1.0.05 firmware listed (and would I be able to via the web interface?)

Thanks again for the quick response, it would be totally awesome if I could get OpenWrt installed on this!

Hi,

So, when you load the um_factory_fw.bin it loads OpenWRT to memory only. You should enter the OpenWRT interface in a browser at 192.168.1.1 and flash the sysupgrade file from the System/Administration tab. Then, upon reboot, you should be running OpenWRT.

It's important to make sure you are using the correct file for the RE6500 - here's the link:

Once there you'll find two files to download - one intramfs, and one sysupgrade. Rename the intramfs file as directed above in the directions. The directions I provided should work assuming you are using the correct firmware. I don't know if your current OEM firmware is blocking OpenWRT or not. When I loaded OpenWRt on my RE6500's it was an earlier OEM firmware.

The sysupgrade file can be loaded from anywhere.

Good luck!

Thank you so much! None of the bin files worked at the initial link, but using it, I was able to go back to the 17.01.2 release. From there, I downloaded the initramfs file and the sysupgrade file. I was then able to boot the RE6500 from the live initramfs file, but on the earlier 17.01.2 release. Once booted successfully, I flashed the sysupgrade file, and this was also the 17.01.2 that I downloaded earlier. After this flashed successfully, I was able to flash the latest sysupgrade file (19.07.5). Now I have a working OpenWRT installation! Thanks for your help!
So to summarize (for later searches), if the latest version of the firmware doesn't work, try an older version. (I should have tried this much earlier).
The link where I found the later (working) versions:
https://downloads.openwrt.org/releases/17.01.2/targets/ramips/mt7621/

1 Like

Great! I was able to install OpenWRT using 19.07.0, I believe. Glad you got it working.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.