RE450 V3 5GHz perfomance

Hi everyone,

I know, this is a topic that we see a lot here. Since I couldn't find any other option to improve my 5Ghz performance, I decided to open this one.

I'm using a TP-Link RE450 V3, with OpenWrt 21.02.1 r16325-88151b8303, 5Ghz wifi using 80Mhz, and I cannot get any more of 300mbps from my Internet on this AP. I have another AP from Ubiquiti and I can reach the 500Mbps while using it.

VMM is enabled and offloading settings under firewall also. I've tested multiple configurations and couldn't make it perform any better. With the stock firmware, the vendor announce max of 1300Mbps. Is this any OpenWRT limitation? What am I missing here? Please let me know what configuration details should I share.

Is your Ubiquiti set to VHT80 as well?

Also, 1300 Mbps is the link speed of both wireless radios combined, then rounded. Marketing guys typically get there by adding 866 Mbps (802.11ac 5 GHz) with 450 Mbps (2,4 GHz). Needless to say you will never see those 'speeds' materialise as it's a smokescreen to sell bigger numbers (and alas, it works...).

Add overhead and the fact wireless is a half-duplex medium, and you might top out at anything around 400 Mbps best case on your 5 GHz link. But rarely more. So I'd be surprised if you saw 500 Mbps unless your Ubiquiti has more streams and you got a powerful client (three antennae?). Typical clients are 1 or 2 streams (smartphones, laptops, ...).

2 Likes

Yeah, I understand the marketing thing, but my expectations is reach the internet max connection speed (500Mbps). My Ubiquiti AP is also using 80Mhz and I can get 500Mbps on my mobile device and using my laptop, within a short range. I imagine that we have 3 antennas on it, but so this TP-Link device.

Seeing the connection bitrate, I get this:
Qualcomm Atheros QCA9880 802.11nac
Channel: 157 (5.785 GHz) | Bitrate: 780 Mbit/s

So where is the bottleneck here? Device, ethernet?

Those are link speeds. Not actual transmission speeds. See part 2 of my explanation above.

I see your 5 GHz radio is three-stream, so 433 x3 does indeed equal 1300 Mbps, but that's link speed. Are you sure your laptop uses three streams? Very few do, if any. Most only have two antennae.

Speeds might be higher with OEM firmware, but it will never come anywhere close to the link speeds. That's not how link speeds work.

Using my laptop connected to TP-link, I get this from my mobile and laptop:

Connected to Ubiquiti, I get this from my mobile and laptop:

Hi, @roterigopt,

I've same device with OpenWrt, even this being a 3x3 device your final speed will be mainly driven by your link speed. You are reporting 780 link speed, attainable real speed usually is 40-60% of speed link, so around 300-450 Mbps, usually landing on the low side of it. I will say your speedtest is correct.

Just one note, I have my transmission power set to 15dbm to avoid signal overlap with the other ap. I've tested with maximum power and I'm not seeing any influence.

I've been doing some more tests and I notice that there's a cap of 300Mbps. I've tried using 40Mhz or 80Mhz and I always reach the same limit. It doesn't seem hardware limitation, otherwise we wouldn't have 1200Mbps with the stock firmware. Can it be some configuration or firmware limitation?

This is mine connected to my main router:

And this is my test with my computer connected via Ethernet to it and executing against my main router, so connection is as follows:

Computer --Eth--> RE450 --WiFi--> nanoHD --Eth--> Router

Here yo go:

@grim$ ➜  ~ iperf3 -R -c 192.168.1.1
Connecting to host 192.168.1.1, port 5201
Reverse mode, remote host 192.168.1.1 is sending
[  5] local 192.168.1.134 port 49740 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  58.7 MBytes   493 Mbits/sec
[  5]   1.00-2.00   sec  59.9 MBytes   502 Mbits/sec
[  5]   2.00-3.00   sec  61.9 MBytes   519 Mbits/sec
[  5]   3.00-4.00   sec  58.8 MBytes   494 Mbits/sec
[  5]   4.00-5.00   sec  62.3 MBytes   522 Mbits/sec
[  5]   5.00-6.00   sec  60.8 MBytes   510 Mbits/sec
[  5]   6.00-7.00   sec  60.4 MBytes   507 Mbits/sec
[  5]   7.00-8.00   sec  61.9 MBytes   519 Mbits/sec
[  5]   8.00-9.00   sec  61.0 MBytes   512 Mbits/sec
[  5]   9.00-10.00  sec  59.6 MBytes   499 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.01  sec   609 MBytes   510 Mbits/sec    1             sender
[  5]   0.00-10.00  sec   605 MBytes   508 Mbits/sec                  receiver

iperf Done.

Maybe a bit on the low side but I don't expect much more from this little toy. Might be the case that changing from ath10k-ct to the former ath10k things improve? Don't know.

It's running OpenWrt SNAPSHOT, r18468-4a2cca7824, BTW.

Thanks for the suggestion. You are using yours as a client, right? It's a good idea, I will try with the previous ath10k build. I don't have much experience with this, but I imagine that is only a matter of finding the last firmware using that driver and install it via GUI, right?

You can swap them out, you don't need to replace the whole firmware. Just the matching packages (kmod & firmware for your kernel). You can go back and forth like that.

Correct, I use it as a client to provide Ethernet connectivity to one of my NVIDIA SHIELD TVs.

@roterigopt, this should work for you.

opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct-smallbuffers
opkg install ath10k-firmware-qca988x kmod-ath10k

And you have another version to test too, kmod-ath10k-ct, just in case.

1 Like

Thanks. Will give it a try. I will share updates after...

@amteza do you know if we can install the snapshot build (meaning, install and older version) directly from Luci (webUI)?

Sure you can. I build mine using ImageBuilder and then I upgrade the system (or downgrade) on LuCI using the sysupgrade image. It already worked a half dozen of times with no issues.