RE350 can't access via ssh or telnet to configure

Hello everyone,

I have a TP-Link RE350, and I wanted to install OpenWrt. I went to the TP-Link configuration page for the device, and uploaded this firmware ( from which I got from here ( and it seemed as if the firmware successfully installed as the device appeared on my network after booting up for the first time with OpenWrt installed. I looked at my main router settings and found that it is located at the IP address of, so I put that into putty so I can access the extender via ssh, and it would give me the error message "connection timed out." I also tried via telnet, and for every try with either ssh or telnet, it would attempt to connect for about 10 seconds and then tell me that it timed out. The extender is connected via the ethernet port directly to the router from my internet service provider, and there are currently no issues with my internet. I am using putty from my windows 10 laptop, and I am connected to my home wifi with it.

Any help would be greatly appreciated!
Matthew Vandenberg

P.S. Bare with me, I've never tried to flash a router or extender with OpenWrt or flash in general before; I'm extremely new to this kind of stuff!

  • Is there a reason you're using shortlinks? It's hard to determine that you're using official software.
  • The default IP is If you see .10, perhaps you have a used router that was flashed by its previous owner in the past.
  • OpenWrt has WiFi disabled by default.

You need to confirm that you flashed OpenWrt successfully.


I used the shortlinks to make the message smaller, they are the real thing. Also, my main router at home uses, so there’s no way my extender would show up as that since it’s not the main “router”. Using ssh to either one of those IP addresses doesn’t work so I can’t get to the extended to configure OpenWrt.

Sure there's a way...especially if you never changed the default configs, or improperly configured something...

But if you're referring to getting a WAN IP of you need to ensure 2 things:

  • That you properly configured the IP space on the device not con conflict with the "main" device
  • That if you created another firewall zone (or are using WAN), that you've opened the firewall on that interface to access 80/tcp (HTTP) and 22/tcp (SSH) - to access the router.

How should I be trying to connect to the extender to get to openwrt, with ssh or a web browser? Also, I am sure that those ports are open on my home network. Currently, the extender has the power light on and both ethernet lights flashing. The extender will also react when I press the "reset" button, however the extender just goes back into this state of me trying to connect to it. Also, the device shows up on my home network, so I wouldn't think this is an issue with ip space reservations. Remember that the main router in my house is configured as, so the extender, which is the device I am trying to use OpenWrt on, would have to show up as another IP address when it attempts to connect to my home network.

To be clear, you should be connecting to the OpenWrt to reach it, not another device. OpenWrt accepts connections via HTTP and SSH by default. You can use its IP address.

Also, regarding your first post:

It seems you connected to your upstream router using the WAN/Internet interfaces on the OpenWrt.

I'm not so sure.

  • AGAIN - If the OpenWrt device is connected on WAN, the firewall is closed on the WAN side - you will have to access the device from LAN and open the firewall!
  • Also, you have to renumber the OpenWrt's LAN, as your upstream router also uses the subnet