RE200 v4 cannot connect via 5GHz

Has anyone tried to connect to 5GHz (via radio1) as a client (sta) on the TP-LINK RE200 v4? It doesn't want to connect, whether the network is open or not, hidden or not.

Huh, I'm lost...because I'm not sure you're referencing the OpenWrt-side.

Are you saying that you can't:

  1. connect to an 5.4 GHz AP configured on the RE200 v4 running OpenWrt; or
  2. can't use the RE200 v4's 5 GHz to connect to an upstream device?

It seems like number 1...in any case can you provide the configs?

My guess without further details is that you set a channel or have an AP set too.

Connect to upstream device. RE200 (radio1 - MT7610) is configured as client (sta) with proper password, psk2 etc, as wan zone.

Well, as I said...

Also, need to know if you also have a 5.4 GHz AP - your configs will show all we [should] need to assist.

Yes, I have. Really, I have other devices connected via 5GHz...

wireless:

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'wan'
	option mode 'sta'
	option ssid 'myssid'
	option encryption 'psk2'
	option key 'mypassword'

network

config interface 'wan'
	option proto 'dhcp'

Standard config, nothing special. Log:

Tue Nov 10 19:29:00 2020 kern.info kernel: [  123.123689] wlan1: deauthenticating from xx:xx:xx:xx:xx by local choice (Reason: 3=DEAUTH_LEAVING)
Tue Nov 10 19:29:00 2020 daemon.notice wpa_supplicant[3031]: wlan1: CTRL-EVENT-DISCONNECTED bssid=xx:xx:xx:xx:xx reason=3 locally_generated=1
# ifstatus wan
{
	"up": false,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"proto": "dhcp",
	"device": "wlan1",
	"data": {
		
	}
}

Can anyone confirm that the sta mode works for him on the mt7610 chipset?

You wifi-device is missing a county setting. Since you run an AP too, this is definitely a problem.

So where is this config?

Need to see the whole config.

Yes.

No... Again, RE200 is client and only client, not ap + sta.

I dont understand you. What config? From different client? What does this have to do with RE200?

Okay, I'm sure I asked that and you said:

At any rate, you need a country setting.

This is because in some Nations (and in International areas) 5.4 GHz is not allowed to initiate radio emissions.

So, what happened when you added it?

Nothing special. Add the option country PL, it also does not connect.

Other devices (like ipq40xx) connect fine, with or without option country. So problem is in driver mt76 or chipset mt7610.