RE200 client mode (sta) does not work

I have found similar issues in the forum with no solution. I remember like more than 1 year ago I successfully used an RE200 (v3 in my case) as a WDS repeater, with a snapshot firmware.

But now with 21.02.2 and 21.02.3 this seems to fails always. The extender sometimes associates to initiate the WPA2 handshake but never finishes OK.

Here is an example of configuration

wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.hwmode='11a'
wireless.radio1.path='pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio1.country='AR'
wireless.radio1.htmode='VHT40'
wireless.radio1.channel='56'

wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='OpenWrt'
wireless.default_radio1.encryption='psk2'
wireless.default_radio1.key='kjhckjh123'
wireless.default_radio1.disabled='1'

wireless.wifinet2=wifi-iface
wireless.wifinet2.device='radio1'
wireless.wifinet2.mode='sta'
wireless.wifinet2.network='wwan'
wireless.wifinet2.ssid='Pablomagno'
wireless.wifinet2.key='pablopablo123'
wireless.wifinet2.ifname='backhaul'
wireless.wifinet2.encryption='psk2'

As you can see the AP interface is turned of to test with the STA interface alone first. This is a common STA connection, the behavior is the same with WDS, again I went back to common STA mode for reducing the problem as the simplest case for debug.

Anyone still having this issues with this device?

Depending on your geographic location, channel 56 is a DFS (radar) channel.

Run iw list and see which 5 GHz channels are available, and at what transmit power level.

Just to clarify, I tried with coutry code "IN" which has no DFS (also UNII-2 ext). But this does not seems to help :sweat_smile:

Use your country code, and select a non-DFS channel.

Use a WiFi app to see who is using what channels in your area, your signal strength, and your signal-to-noise ratio (SNR).

You might edit your post above to redact the keys...if those are your actual passwords.

I have already done all of that. Changing the country code is just for troubleshooting. I have here three diferent devices (Archer C7v5, WA 1201 v2 and the RE200 v3) and with the same configuration and wpad package two of them work (with 21.02.2/3 Archer C7 and WA 1201 with a recent snapshot) while this device seems to be unable to do that.

The configuration is just an example, I have done several tests in all the channels and different country codes.

The passwords are not a matter as they are for testing, they are not passwords associated to any personal or confidential usage. Anyway, thanks for the advice.

Are you using WPA2-PSK with AES?

I don't see psk2+ccmp for encryption.

Yes, and as I checked there are three equivalent expression for WPA2/AES:

I will come back with wpa_cli messages and maybe an air capture, if it helps to understand something more.

Well, here is the update.

I have tested in three diferent modes: normal STA (in a diferent network "wwan"), WDS and multi_ap (100 % 802.11 WDS). 5.8 GHz radio, diferent channels, channel bondings, no DFS, in all cases I have got:

------------------------------------------------------- 1) Normal STA ---------------------------------------------------

The connection is successfully stablished only if there is no BSS enabled (I have also configured a BSS (AP) which I had to disable in order to make this work. The goal was to achieve the dual mode operation (STA+AP, as the stock firmware does) but this seems to not be possible. The configuration in UCI was:

wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.path='pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio1.band='5g'
wireless.radio1.cell_density='0'
wireless.radio1.country='AR'
wireless.radio1.htmode='VHT40'
wireless.radio1.channel='149'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='OpenWrt'
wireless.default_radio1.key='123456987'
wireless.default_radio1.macaddr='00:31:92:04:09:51'
wireless.default_radio1.encryption='psk2+ccmp'
wireless.wifinet2=wifi-iface
wireless.wifinet2.device='radio1'
wireless.wifinet2.mode='sta'
wireless.wifinet2.network='wwan'
wireless.wifinet2.ssid='Pablomagno'
wireless.wifinet2.key='password'
wireless.wifinet2.macaddr='00:31:92:04:09:50'
wireless.wifinet2.encryption='psk2+ccmp'

When the AP is enabled, there is no irradiation of beacons or anything and the STA starts with the probe requests/responses, then the Authentication frames and that is all, no association or WPA2. Then it enters in a loop of retries doing the same. This can be seen in the capture.

Here are the logs in wpa_cli regarding this state:

<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Pablomagno" auth_failures=1 duration=10 reason=CONN_FAILED
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SSID-REENABLED id=0 ssid="Pablomagno"
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Pablomagno" auth_failures=2 duration=20 reason=CONN_FAILED
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SSID-REENABLED id=0 ssid="Pablomagno"
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Pablomagno" auth_failures=3 duration=30 reason=CONN_FAILED
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-SSID-REENABLED id=0 ssid="Pablomagno"
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>CTRL-EVENT-NETWORK-NOT-FOUND
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE
<3>SME: Trying to authenticate with 44:d4:54:a0:0c:f3 (SSID='Pablomagno' freq=5745 MHz)
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Pablomagno" auth_failures=4 duration=60 reason=CONN_FAILED
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>WPS-AP-AVAILABLE

-------------------------------------------- 2) WDS and MAP WDS --------------------------------------------------

Here the situation is worse, Always fails, the behavior is the same as the failure case with normal STA mode, but now I simply won't work in any situation. The configuration is the following:

# Radio config

wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.path='pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio1.band='5g'
wireless.radio1.cell_density='0'
wireless.radio1.country='AR'
wireless.radio1.htmode='VHT40'
wireless.radio1.channel='149'

# AP config

wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='OpenWrt'
wireless.default_radio1.key='123456987'
wireless.default_radio1.macaddr='00:31:92:04:09:51'
wireless.default_radio1.encryption='psk2+ccmp'
 
# Traditional WDS STA

wireless.wifinet2=wifi-iface
wireless.wifinet2.device='radio1'
wireless.wifinet2.mode='sta'
wireless.wifinet2.macaddr='00:31:92:04:09:50'
wireless.wifinet2.encryption='psk2+ccmp'
wireless.wifinet2.key='12345678'
wireless.wifinet2.ssid='TestWDS'
wireless.wifinet2.wds='1'
wireless.wifinet2.network='lan'


# Multi AP WDS STA

wireless.wifinet2=wifi-iface
wireless.wifinet2.device='radio1'
wireless.wifinet2.mode='sta'
wireless.wifinet2.macaddr='00:31:92:04:09:50'
wireless.wifinet2.encryption='psk2+ccmp'
wireless.wifinet2.key='12345678'
wireless.wifinet2.ssid='TestWDS'
wireless.wifinet2.multi_ap='1'
wireless.wifinet2.network='lan'

The AP which it should connect to works with another devices in both modes.

I also want to remember that asi I said, in the past (October/November 2020) with a snapshot I achieved this in regular WDS and Multi AP WDS, in dual mode AP+STA in the same radio. But now with 21.02.2 (all the tests were done with this version) and 21.02.3 this seems to be impossible