Re-configuring network

Hello,

I have brought some new hardware to improve my home network.

Currently:
Netgear DGN3500 running OpenWRT supplying all the internet/wifi

I have recently brought:
TP-Link Archer C50
Asus RT-66U
Asus RT-AC3100 (DSL 88U)

I am looking to keep either the DGN3500 as the modem (or possibly swapping in the RT-AC3100) and running the other 2 routers as a switch/wifi extenders.

Is this the best way or should I consider something else.

SIDENOTE:
I am trying to install Luci on the ArcherC50 but unable to 'opkg update'
I configured it as a dump-ap which all works fine but I am unable to connect back (ssh) once I do this.

Current gateway is 192.168.1.1 (DGB3500 Working)
IP for Archer was set to both static 192.168.1.2 and DCHP (both not working) also tried adding the gateway and dns option to the config (pointing to 192.168.1.1) but still not working.

Thanks

It depends on the area you want to cover, but I don't see any issue with that.

Maybe the new IP was not applied correctly? I cannot think of another problem. Did you follow the guide in the wiki to make the dumbAP?

1 Like

Yes followed the guide, and internet was working on the ArcherC50 (Ethernet connections) but the once I configure the dumb-ap the router loses its IP and can't ssh into it anymore (boot failsafe and reset required)

My DGN3500 was showing its IP as 192.168.1.153 in the DCHP table but tried ssh'ing into that with no luck.

Are you connecting the Archer from WAN port or LAN to the DGN?

Tried both lan and wan, the dumb-ap (internet) still worked but can't ssh using either

The only reason I can think of is that you have left the WAN firewall zone active, hence the blocking of incoming SSH.
When configuring the dumbAP it is safe to remove the WAN firewall zone and interface, then proceed to configure the LAN interface as dhcp client or static IP, switch off DHCP server and optionally bridge the physical wan port to the LAN.

Just tried it again and saved the config files.
Now both 192.168.1.1 (DGN3500)
and 192.168.1.2 (ArcherC50) are accessible but opkg doesn't want to work, even though there is interne.t.

Physically bridging the wan and lan ports makes the internet connection drop instantly.

SSH Output:

login as: root


BusyBox v1.24.2 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 DESIGNATED DRIVER (Bleeding Edge, 50140)
 -----------------------------------------------------
  * 2 oz. Orange Juice         Combine all juices in a
  * 2 oz. Pineapple Juice      tall glass filled with
  * 2 oz. Grapefruit Juice     ice, stir well.
  * 2 oz. Cranberry Juice
 -----------------------------------------------------
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.sig, wget returned 4.
root@OpenWrt:~# wget http://downloads.lede-project.org/releases/17.01.4/packages
/mips_24kc/base/Packages.gz
Downloading 'http://downloads.lede-project.org/releases/17.01.4/packages/mips_24kc/base/Packages.gz'
Failed to establish connection
root@OpenWrt:~#
root@OpenWrt:~#
root@OpenWrt:~# login as: root
Password: Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.gz.
Failed to establish connection

Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.gz.
Failed to establish connection
Downloading http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.sig.
Failed to establish connection
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/base/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/kernel/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/luci/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/management/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/packages/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/routing/Packages.sig, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.gz, wget returned 4.
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/packages/telephony/Packages.sig, wget returned 4.

/etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd32:19c2:5bde::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 eth0.2'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '84:16:f9:9e:c3:6c'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'


/etc/config/firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

# allow IPsec/ESP and ISAKMP passthrough
config rule
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

/etc/config/dchp


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

#config dhcp 'lan'
#	option interface 'lan'
#	option start '100'
#	option limit '150'
#	option leasetime '12h'
#	option dhcpv6 'server'
#	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'


On the 1.2 machine you also need to set DNS to point to 1.1 the same as the gateway.

Try ping 8.8.8.8, that should work but right now ping openwrt.org won't work because names can't be resolved.

2 Likes

so under network
interface lan
add option dns '192.168.1.1'
?

Thanks that worked this time.
Must have stuffed something up when I tried it last.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

Thanks for your help also trendy

1 Like